zoukankan      html  css  js  c++  java
  • UVA 408 (13.07.28)

     Uniform Generator 

    Computer simulations often require random numbers. One way to generatepseudo-random numbers is via a function of the form

    displaymath29

    where `` tex2html_wrap_inline31 " is the modulus operator.

    Such a function will generate pseudo-random numbers (seed) between 0 andMOD-1. One problem with functions of this form is that they will alwaysgenerate the same pattern over and over. In order to minimize thiseffect, selecting the STEP and MOD values carefully can result in auniform distribution of all values between (and including) 0 and MOD-1.

    For example, if STEP = 3 and MOD = 5, the function will generate theseries of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In thisexample, all of the numbers between and including 0 and MOD-1 will begenerated every MOD iterations of the function. Note that by the natureof the function to generate the same seed(x+1) every time seed(x)occurs means that if a function will generate all the numbers between 0 andMOD-1, it will generate pseudo-random numbers uniformly withevery MOD iterations.

    If STEP = 15 and MOD = 20, the function generates the series0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0).This is a poor selection of STEP and MOD because no initial seedwill generate all of the numbers from 0 and MOD-1.

    Your program will determine if choices of STEP and MOD willgenerate a uniform distribution of pseudo-random numbers.

    Input

    Each line of input will contain a pair of integers for STEPand MOD in that order ( tex2html_wrap_inline77 ).

    Output

    For each line of input, your program should print the STEP value right-justified in columns 1 through 10, the MOD value right-justified incolumns 11 through 20 and either ``Good Choice" or ``Bad Choice"left-justified starting in column 25. The ``Good Choice" message shouldbe printed when the selection of STEP and MOD will generate allthe numbers between and including 0 and MOD-1 when MOD numbers aregenerated. Otherwise, your program should print the message ``Bad Choice".After each output test set, your program should print exactly one blank line.

    Sample Input

    3 5
    15 20
    63923 99999

    Sample Output

    3         5    Good Choice
    
            15        20    Bad Choice
    
         63923     99999    Good Choice
    
    
    题意:根据给出的step和mod, 能否用题目中给的出的公式, 得到0到mod-1的余数
    
    做法:要用线性同余方程, 其实也可以求是否两个数互质~
    
    AC代码:
    #include<stdio.h>
    
    int gcd(int a, int b) {
    	return b == 0 ? a : gcd(b, a % b);
    }
    
    int main() {
    	int step, mod;
    	while(scanf("%d%d", &step, &mod) != EOF) {
    		printf("%10d%10d    ", step, mod);
    		if(gcd(step, mod) == 1)
    			printf("Good Choice
    
    ");
    		else
    			printf("Bad Choice
    
    ");
    	}
    	return 0;
    }
  • 相关阅读:
    网摘:微软暗示将推出iPad版本Office
    Android的缘分和FarMap新版发布
    过年发生的,WinM7推出,MeeGo诞生,iPhone香肠
    gPhone体验和思考(一)
    位图的像素操作练习(20120525)
    远图 安致版上线(FarMap Android)
    iPhone的创意,iPhone应用的覆盖
    201871010101陈来弟《面向对象程序设计(java)》第一周学习总结 201871010101
    sdk&mfc&vcl
    ASP.NET中的Web.config详解
  • 原文地址:https://www.cnblogs.com/jiangu66/p/3226245.html
Copyright © 2011-2022 走看看