zoukankan      html  css  js  c++  java
  • 最小生成树 E

    Sunny Cup 2003 - Preliminary Round

    April 20th, 12:00 - 17:00

    Problem E: QS Network


    In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

    A sample is shown below:


    A sample QS network, and QS A want to send a message.

    Step 1. QS A sends message to QS B and QS C;

    Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

    Step 3. the procedure terminates because all the QS received the message.

    Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.

    Input

    The 1st line of the input contains an integer t which indicates the number of data sets.

    From the second line there are t data sets.

    In a single data set,the 1st line contains an interger n which indicates the number of QS.

    The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

    In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

    Constrains:

    all the integers in the input are non-negative and not more than 1000.

    Output

    for each data set,output the minimum cost in a line. NO extra empty lines needed.

    Sample Input

    1
    3
    10 20 30
    0 100 200
    100 0 300
    200 300 0

    Sample Output

    370

    #include<iostream>
    #include<string>
    #include<algorithm>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<iomanip>
    using namespace std;
    #define MAXN 1004
    #define INF 0x3f3f3f3f
    int g[MAXN][MAXN],lowcost[MAXN],p[MAXN],n;
    bool been[MAXN];
    int Prim(int beg)
    {
        int ans = 0;
        memset(been,false,sizeof(been));
        for(int i=1;i<=n;i++)
        {
            lowcost[i] = g[beg][i];
        }
        been[beg] = true;
        for(int j=1;j<n;j++)
        {
            int Minc = INF,k=-1;
            for(int i=1;i<=n;i++)
            {
                if(!been[i]&&lowcost[i]<Minc)
                {
                    Minc = lowcost[i];
                    k = i;
                }
            }
            if(k==-1) return -1;
            been[k] = true;
            ans+=Minc;
            for(int i=1;i<=n;i++)
            {
                if(!been[i]&&lowcost[i]>g[k][i])
                {
                    lowcost[i] = g[k][i];
                }
            }
        }
        return ans;
    }
    int main()
    {
        int t,tmp;
        cin>>t;
        while(t--)
        {
            cin>>n;
            for(int i=1;i<=n;i++)
            {
                cin>>p[i];
            }
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    cin>>tmp;
                    if(i!=j)
                        g[i][j] = p[i]+p[j]+tmp;
                    else
                        g[i][j] = tmp;
                }
            }
            int ans = Prim(1);
            cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    c++ ShellExecuteEx调用java打包的exe程序
    麻省理工学院公开课-第四讲:快速排序 及 随机化 算法
    Win10的IIS与以前版本的一个区别
    干就行了!!!写程序就像珊瑚,分支太多,哪有那么多复用!
    NPoco的使用方法
    为什么前端要写标准代码?
    对于委托、事件、观察者模式最一目了然的代码段
    delphi处理消息的几种方式
    哎呀妈呀,吓死我了,幸好服务器没崩溃。
    Delphi的Hint介绍以及用其重写气泡提示以达到好看的效果
  • 原文地址:https://www.cnblogs.com/joeylee97/p/6590108.html
Copyright © 2011-2022 走看看