zoukankan      html  css  js  c++  java
  • 博弈论入门题 kiki's game

    Problem Description
    Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
     
    Input
    Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

     
    Output
    If kiki wins the game printf "Wonderful!", else "What a pity!".
     
    Sample Input
    5 3 5 4 6 6 0 0
     
    Sample Output
    What a pity! Wonderful! Wonderful!
     
    Author
    月野兔
     
    Source
     
    Recommend
    威士忌   |   We have carefully selected several similar problems for you:  1846 1847 1848 1849 1517 
     
     
     
    显然(1,1)是必败态,因为没有操作可以选择
    那么由必胜态的定义(一步之内能走到必败态的状态叫必胜态)(1,2),(2,2),(2,1)都是必胜态
    依次类推可以打一个表出来(必败态:下一步无论怎样转移都会转移到必胜态)
    找规律
    n,m都是奇数的时候会输!
    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<cstring>
    #include<sstream>
    #include<algorithm>
    #include<queue>
    #include<deque>
    #include<iomanip>
    #include<vector>
    #include<cmath>
    #include<map>
    #include<stack>
    #include<set>
    #include<functional>
    #include<fstream>
    #include<memory>
    #include<list>
    #include<string>
    using namespace std;
    typedef long long LL;
    typedef unsigned long long ULL;
    
    #define N 100
    #define MAXN 20000 + 9
    #define INF 1000000009
    #define eps 0.00000001
    #define sf(a) scanf("%d",&a)
    
    int n;
    int a[N];
    int main()
    {
        while (sf(n), n)
        {
            int sum = 0;
            for (int i = 0; i < n; i++)
                sf(a[i]), sum ^= a[i];
            if (sum == 0)
                cout << 0 << endl;
            else
            {
                int ans = 0;
                for (int i = 0; i < n; i++)
                {
                    if ((sum^a[i]) < a[i])
                        ans++;
                }
                cout << ans << endl;
            }
        }
    }
  • 相关阅读:
    spring boot 配置rabbitmq启动遇到的问题
    linux 启动rabbitmq 报错:
    spring boot 读取自定义properties文件
    jvm笔记-02-垃圾收集器与内存分配策略
    Jvm笔记-01-Java运行时数据区域与对象
    C++ 14 重载操作符与转换
    C++ 13 复制控制
    C++ 12 类
    C++ 11 泛型算法、迭代器
    android studio 问题及处理记录
  • 原文地址:https://www.cnblogs.com/joeylee97/p/7497420.html
Copyright © 2011-2022 走看看