zoukankan      html  css  js  c++  java
  • poj 1936 All In All

    All in All
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 31536   Accepted: 13070

    Description

    You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

    Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

    Input

    The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

    Output

    For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

    Sample Input

    sequence subsequence
    person compression
    VERDI vivaVittorioEmanueleReDiItalia
    caseDoesMatter CaseDoesMatter
    

    Sample Output

    Yes
    No
    Yes
    No
    

    Java AC 代码:

    import java.util.Scanner;
    
    public class Main {
        
        public static void main(String[] args) {
            String s = "";
            String t = "";
            Scanner sc = new Scanner(System.in);
            int sIndex = 0;
            int tIndex = 0;
            while((s = sc.next()) != "" && (t = sc.next()) != "") {
                
                if(s.length() > t.length()) {
                    System.out.println("No");
                    continue;
                }
                int sLen = s.length();
                int tLen = t.length();
                while(sIndex < sLen && tIndex < tLen) {
                    if(s.substring(sIndex, sIndex + 1).equals(t.substring(tIndex, tIndex + 1))) {
                        sIndex ++;
                    }
                    tIndex ++;
                }
                if(sIndex == sLen)
                    System.out.println("Yes");
                else 
                    System.out.println("No");
                sIndex = 0;
                tIndex = 0;
            }
            
        }
    }
  • 相关阅读:
    陈欧代言
    location传值
    jsp中button传值
    电影
    排序
    比较两个字符,相等输出yes,不相等输出no
    查表求平方值
    数据库查询调优(SQL 2008)
    HelloWorld
    关于缓存 (这个自己也在慢慢学习,慢慢总结中,有路过的,求指点,赶紧不尽。。。)
  • 原文地址:https://www.cnblogs.com/kkkkkk/p/5546153.html
Copyright © 2011-2022 走看看