zoukankan      html  css  js  c++  java
  • POJ 1125 Stockbroker Grapevine(最短路基础题)

    Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

    Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

    Input

    Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

    Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

    Output

    For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
    It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

    Sample Input

    3
    2 2 4 3 5
    2 1 2 3 6
    2 1 2 2 2
    5
    3 4 4 2 8 5 3
    1 5 8
    4 1 6 4 10 2 7 5 2
    0
    2 2 5 1 5
    0

    Sample Output

    3 2
    3 10

    思路:
    先用最短路找一下i-j的最短路径,然后只要找到第i个经纪人的的最长路径也就是最晚接到消息的时间,这就是这个经纪人的耗时,只要比较下所有经济人中耗时最短的就是我们要找的。
    至于不连通的这个很容易解决,只要初始化给每条路径一个初始的值(一个很大的数字),floyd之后只要再遍历一遍i经纪人的最长路径,如果他的最长路径是初始值的话,说明有路径
    没有连通,直接输出disjoint就好了。这只是数据比较小可以用floyd解决,如果数据比较大的话还好,还是要用其他耗时比较低的算法,比如spfa算法。

    实现代码:
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using  namespace std;
    #define INF 0x3f3f3f3f
    #define maxx 9999999
    int mp[120][120],n;
    void floyd(){
        for(int i = 1;i <= n; i++){
            for(int j = 1;j <= n; j++){
                for(int k = 1;k <= n; k++){
                    if(mp[j][k] > mp[j][i]+mp[i][k])
                        mp[j][k] = mp[j][i] + mp[i][k];
                }
            }
        }
    }
    int main()
    {
        int i,j,minn,minx,m,x,y;
        while(scanf("%d",&n)&&n){
            minn = maxx;
            for(i=1;i<=n;i++)
                for(j=1;j<=n;j++)
                    mp[i][j] = mp[j][i] =  maxx;
            for(i=1;i<=n;i++){
                scanf("%d",&m);
                while(m--){
                    scanf("%d%d",&x,&y);
                    mp[i][x] = y;
                }
            }
            floyd();
            for(i=1;i<=n;i++){
                int ans = 0;
                for(j=1;j<=n;j++){
                    if(i!=j&&mp[i][j]>ans)
                    ans = mp[i][j];
                }
            if(ans<minn){
                minn = ans;
                minx = i;
            }
            }
            if(minn == maxx) cout<<"disjoint"<<endl;
            else cout<<minx<<" "<<minn<<endl;
          memset(mp,INF,sizeof(mp));
        }
    }
     
  • 相关阅读:
    12套有用的免费 PSD 格式 Android UI 素材
    使用 Canvas 和 JavaScript 创建逼真的下雨效果
    在网页设计中使用漂亮字体的16个优秀例子
    Koala – 开源的前端预处理器语言图形编译工具
    BackgroundCheck – 根据图片亮度智能切换元素样式
    经典网页设计:18个示例展示图片在网页中的使用
    TogetherJS – 酷!在网站中添加在线实时协作功能
    30个令人惊叹的灵感来自自然风光的网站设计《下篇》
    太有才了!创新的街头涂鸦手绘欣赏【中篇】
    15款美丽的设备模板,帮助展示你的 APP
  • 原文地址:https://www.cnblogs.com/kls123/p/7910289.html
Copyright © 2011-2022 走看看