zoukankan      html  css  js  c++  java
  • POJ 1961 Period(KMP求一个串的重复子串)

    Period
    Time Limit: 3000MS   Memory Limit: 30000K
    Total Submissions: 9696   Accepted: 4428

    Description

    For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

    Input

    The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
    number zero on it.

    Output

    For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

    Sample Input

    3
    aaa
    12
    aabaabaabaab
    0

    Sample Output

    Test case #1
    2 2
    3 3
    
    Test case #2
    2 2
    6 2
    9 3
    12 4

    Source

     
     
     
    题意:即求一个字符串的最大重复字串。
     
     
    借助KMP中的next数组
     
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    
    const int MAXN=1000010;
    char str[MAXN];
    int next[MAXN];
    int n;
    void getNext()
    {
        int j,k;
        j=0;
        k=-1;
        next[0]=-1;
        while(str[j]!='\0')
        {
            if(k==-1||str[j]==str[k])
            {
                j++;
                k++;
                if(j%(j-k)==0&&j/(j-k)>1)
                  printf("%d %d\n",j,j/(j-k));
                next[j]=k;
            }
            else k=next[k];
        }
    }
    int main()
    {
      //  freopen("in.txt","r",stdin);
       // freopen("out.txt","w",stdout);
        int iCase=0;
        while(scanf("%d",&n),n)
        {
            iCase++;
            scanf("%s",&str);
            printf("Test case #%d\n",iCase);
            getNext();
            printf("\n");
        }
        return 0;
    }
  • 相关阅读:
    selenium之css selector
    selenium之xpath
    selenium的一些概念
    HTML基础(四)JS
    HTML基础(三)DOM操作
    HTML基础(二)CSS
    HTML基础(一)HTML标签
    python学习笔记(六)发邮件、写日志、操作redis、导入模块
    python学习笔记(五)模块、第三方模块安装、模块导入
    python学习笔记(四)函数(下)、模块、集合
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2625781.html
Copyright © 2011-2022 走看看