zoukankan      html  css  js  c++  java
  • POJ 1026 Cipher(置换)

    Cipher
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 16995   Accepted: 4445

    Description

    Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message.

    The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.

    Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.

    Input

    The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

    Output

    Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

    Sample Input

    10
    4 5 3 7 2 8 1 6 10 9
    1 Hello Bob
    1995 CERC
    0
    0
    

    Sample Output

    BolHeol  b
    C RCE
    
    

    Source

     
    给定1~n的置换F,求其变换m次的变换F^m.
    先找到循环节,再用m对循环节的长度取模即可.
    /*
    POJ 1026
    置换
    仔细研究一下样例,发现每个字母经过一定次数变换
    后一定会回到原来的位置,且这个变换次数肯定不会大于N。
    */
    #include<string.h>
    #include<iostream>
    #include<stdio.h>
    #include<math.h>
    #include<algorithm>
    using namespace std;
    const int MAXN=220;
    char str[MAXN];//原始的字符串
    char ans[MAXN];//最终变换后的字符串,即输出结果
    
    int key[MAXN];//一次变换
    int cir[MAXN][MAXN];//每个循环节成员,cir[i][j]表示以i为开始,变换j次后的结果
    int num[MAXN];//每个循环节长度
    bool vis[MAXN];
    
    
    int main()
    {
       // freopen("in.txt","r",stdin);
       // freopen("out.txt","w",stdout);
        int n,k;
        int cnt;//循环节个数
        while(scanf("%d",&n),n)
        {
            for(int i=1;i<=n;i++)scanf("%d",&key[i]);
            memset(vis,false,sizeof(vis));
            memset(num,0,sizeof(num));
            cnt=0;
            for(int i=1;i<=n;i++)//求所有循环节
            {
                if(vis[i]==false)
                {
                    vis[i]=true;
                    num[cnt]=0;
                    int temp=key[i];
                    cir[cnt][num[cnt]++]=temp;
                    while(!vis[temp])
                    {
                        vis[temp]=true;
                        temp=key[temp];
                        cir[cnt][num[cnt]++]=temp;
                    }
                    cnt++;
                }
    
            }
            while(scanf("%d",&k),k)
            {
                gets(str);//第一个是空格
                int len=strlen(str);
                for(int i=len;i<=n;i++)str[i]=' ';
                str[n+1]='\0';
                for(int i=0;i<cnt;i++)
                  for(int j=0;j<num[i];j++)
                  {
                      ans[cir[i][(j+k)%num[i]]]=str[cir[i][j]];
                  }
                ans[n+1]='\0';
                printf("%s\n",ans+1);
            }
            printf("\n");
        }
        return 0;
    }
  • 相关阅读:
    Mybatis之批量更新操作
    Spring Quartz *.QRTZ_LOCKS' doesn't exist
    分析NTFS文件系统得到特定文件的内容
    设计模式笔记——设计模式原则总结
    android自己定义ViewPager之——3D效果应用
    Android混淆代码
    百度地图 Android SDK
    NYOJ17,单调递增最长子序列
    令人纠结的两行代码
    XCode中在提示窗体中对已弃用的API接口画上红线
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2669660.html
Copyright © 2011-2022 走看看