zoukankan      html  css  js  c++  java
  • HDU 4282 A very hard mathematic problem 第37届ACM/ICPC长春赛区网络赛1005题 (暴力)

    A very hard mathematic problem

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 964    Accepted Submission(s): 279


    Problem Description
      Haoren is very good at solving mathematic problems. Today he is working a problem like this:
      Find three positive integers X, Y and Z (X < Y, Z > 1) that holds
       X^Z + Y^Z + XYZ = K
      where K is another given integer.
      Here the operator “^” means power, e.g., 2^3 = 2 * 2 * 2.
      Finding a solution is quite easy to Haoren. Now he wants to challenge more: What’s the total number of different solutions?
      Surprisingly, he is unable to solve this one. It seems that it’s really a very hard mathematic problem.
      Now, it’s your turn.
     
    Input
      There are multiple test cases.
      For each case, there is only one integer K (0 < K < 2^31) in a line.
      K = 0 implies the end of input.
      
     
    Output
      Output the total number of solutions in a line for each test case.
     
    Sample Input
    9 53 6 0
     
    Sample Output
    1 1 0   
    Hint
    9 = 1^2 + 2^2 + 1 * 2 * 2 53 = 2^3 + 3^3 + 2 * 3 * 3
     
    Source
     
    Recommend
    liuyiding
     
     
     
     
    暴力枚举z就可以了。z肯定比较小的。
    当z等于2时就是平方和公式。
    #include<stdio.h>
    #include<math.h>
    #include<string.h>
    #include<algorithm>
    #include<iostream>
    using namespace std;
    
    long long pow(long long a,int n)
    {
        long long ret=1;
        long long temp=a;
        while(n)
        {
            if(n&1)ret*=temp;
            temp*=temp;
            n>>=1;
        }
        return ret;
    }
    int main()
    {
        long long K;
        long long ans;
        while(scanf("%I64d",&K),K)
        {
            ans=0;
            long long temp=(long long)sqrt(K);
            if(temp*temp==K)ans+=(temp-1)/2;
            for(int z=3;z<31;z++)
            {
                for(long long x=1;;x++)
                {
                    long long u=pow(x,z);
                    if(u*2>=K)break;
                    for(long long y=x+1;;y++)
                    {
                        long long v=pow(y,z);
                        if(u+v+x*y*z>K)break;
                        if(u+v+x*y*z==K)ans++;
                    }
                }
            }
            printf("%I64d\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    remove &#39;^M&#39; in shell script
    MyBatis学习总结——实现关联表查询(转)
    SSM框架下结合 log4j、slf4j打印日志
    intellij IDEA里各图标对应的文件类型
    springboot整合shiro
    在Eclipse中如何关联源代码
    windows7 创建http 服务器
    Intellij IDEA 安装和配置jrebel进行项目的热部署
    IntelliJ IDEA 热部署插件 JRebel 安装激活及使用
    idea 安装热部署插件
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2679010.html
Copyright © 2011-2022 走看看