zoukankan      html  css  js  c++  java
  • HDU 4460 Friend Chains 第37届ACM/ICPC杭州赛区题目 (bfs求最短路,求两两之间最短路的最大值)

    Friend Chains

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 15    Accepted Submission(s): 10


    Problem Description
    For a group of people, there is an idea that everyone is equals to or less than 6 steps away from any other person in the group, by way of introduction. So that a chain of "a friend of a friend" can be made to connect any 2 persons and it contains no more than 7 persons.
    For example, if XXX is YYY’s friend and YYY is ZZZ’s friend, but XXX is not ZZZ's friend, then there is a friend chain of length 2 between XXX and ZZZ. The length of a friend chain is one less than the number of persons in the chain.
    Note that if XXX is YYY’s friend, then YYY is XXX’s friend. Give the group of people and the friend relationship between them. You want to know the minimum value k, which for any two persons in the group, there is a friend chain connecting them and the chain's length is no more than k .
     
    Input
    There are multiple cases.
    For each case, there is an integer N (2<= N <= 1000) which represents the number of people in the group.
    Each of the next N lines contains a string which represents the name of one people. The string consists of alphabet letters and the length of it is no more than 10.
    Then there is a number M (0<= M <= 10000) which represents the number of friend relationships in the group.
    Each of the next M lines contains two names which are separated by a space ,and they are friends.
    Input ends with N = 0.
     
    Output
    For each case, print the minimum value k in one line.
    If the value of k is infinite, then print -1 instead.
     
    Sample Input
    3 XXX YYY ZZZ 2 XXX YYY YYY ZZZ 0
     
    Sample Output
    2
     
    Source
     
    明显是求两两之间的最短路。
    Floyed,O(n^3)明显是超时的。
    做n次bfs求最短路。O(n^2).
     
    写得速度不快,险过了~~~~
    //============================================================================
    // Name        : HDU4460.cpp
    // Author      : 
    // Version     :
    // Copyright   : Your copyright notice
    // Description : Hello World in C++, Ansi-style
    //============================================================================
    
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <map>
    #include <math.h>
    #include <queue>
    #include <vector>
    using namespace std;
    const int MAXN=1010;
    const int INF=0x3f3f3f3f;
    int dis[MAXN][MAXN];
    bool used[MAXN];
    vector<int>vec[MAXN];
    queue<int>que;
    void dfs(int i)
    {
        memset(used,false,sizeof(used));
        dis[i][i]=0;
        used[i]=true;
        que.push(i);
        while(!que.empty())
        {
            int t=que.front();
            que.pop();
            int m=vec[t].size();
            for(int j=0;j<m;j++)
            {
                int v=vec[t][j];
                if(used[v])continue;
                dis[i][v]=dis[i][t]+1;
                que.push(v);
                used[v]=true;
            }
        }
    }
    
    map<string,int>mp;
    int main() {
        string str;
        string str2;
        int n,m;
        while(scanf("%d",&n)==1 && n)
        {
            mp.clear();
            for(int i=0;i<n;i++)
            {
                cin>>str;
                mp[str]=i;
            }
    
            for(int i=0;i<n;i++)
            {
                dis[i][i]=0;
                for(int j=i+1;j<n;j++)
                    dis[i][j]=dis[j][i]=INF;
            }
            scanf("%d",&m);
            for(int i=0;i<n;i++)vec[i].clear();
            while(m--)
            {
                cin>>str>>str2;
                int t1=mp[str];
                int t2=mp[str2];
                vec[t1].push_back(t2);
                vec[t2].push_back(t1);
            }
            for(int i=0;i<n;i++)dfs(i);
            int ans=0;
            for(int i=0;i<n;i++)
                 for(int j=i+1;j<n;j++)
                     ans=max(ans,dis[i][j]);
            if(ans==INF)ans=-1;
            printf("%d\n",ans);
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    DNS子域授权,区域传送
    DNS BIND配置 配置基本缓存服务器 DNS正向解析 DNS反向解析
    DNS服务概念
    【转】Red5流服务器搭建(实现在线直播,流媒体视频播放和在线视频会议)
    CMD命令
    PHP Mysql数据库连接
    Mysql数据库报错1264
    Linux下nginx的安装
    windows下nginx的安装
    【转载】详解 $_SERVER 函数中QUERY_STRING和REQUEST_URI区别
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2761023.html
Copyright © 2011-2022 走看看