zoukankan      html  css  js  c++  java
  • Packets

    A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

    Input

    The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

    Output

    The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

    Sample Input

    0 0 4 0 0 1 
    7 5 1 0 0 0 
    0 0 0 0 0 0 

    Sample Output

    2 
    1 
    贪心,4*4,5*5,6*6的物品每一个都需要一个箱子,3*3的4个装一箱,然后剩下的从大到小进行贪心,2*2的物品装完4*4的箱子还可以装5个,3*3的如果不是恰好装玩,剩下多一个箱子
    如果剩1个还可以装2*2的5个,剩2个装3个,剩3个装1个,还不够加箱子,一个箱子可以装2*2的9个,所有箱子的剩余空间装1*1的。不够装再加箱子,一个箱子可以装1*1的36个。
    #include<iostream>
    #include<cstdio>
    #include<cmath>
    using namespace std;
    typedef long long ll;
    
    int size[101];
    int v[6]={1,4,9,16,25,36};
    int main()
    {
        //freopen("in.txt", "r", stdin);
        ios::sync_with_stdio(false);
        while (1)
        {   
            int flag=1;
            int ans=0;
            for (int i = 0; i < 6; i++)
                {
                    cin >> size[i];
                    if(size[i]!=0)
                        flag=0;
                }
            if(flag)break;
            ans=size[3]+size[4]+size[5]+(size[2]+3)/4;
            int n=size[1]-5*size[3];
            if(size[2]%4==1)n-=5;
            if(size[2]%4==2)n-=3;
            if(size[2]%4==3)n-=1;
            if(n>0)ans+=(n+8)/9;
            int tol=ans*36-size[1]*v[1]-size[2]*v[2]-size[3]*v[3]-size[4]*v[4]-size[5]*v[5];
            if((tol)<size[0])
            ans+=(size[0]-tol+35)/36;
            cout<<ans<<endl;
        }
        return 0;
    }
    View Code
  • 相关阅读:
    Indy的TCPServer到底能支持多少个连接
    Delphi TStream 详细介绍
    WebAPI下的如何实现参数绑定
    使用 Weinre 调试移动网站及 PhoneGap 应用
    面向对象的三大特征:封装、继承、多态
    轻量级前端MVVM框架avalon
    三种工厂模式的分析以及C++实现
    简单实现TCP下的大文件高效传输
    Nunit NMock Ncover单元测试
    算法实践——数独的基本解法
  • 原文地址:https://www.cnblogs.com/kuroko-ghh/p/10300328.html
Copyright © 2011-2022 走看看