zoukankan      html  css  js  c++  java
  • Maximum Product UVA

    Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the
    maximum positive product involving consecutive terms of S. If you cannot find a positive sequence,
    you should consider 0 as the value of the maximum product.
    Input
    Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si
    is
    an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each
    element in the sequence. There is a blank line after each test case. The input is terminated by end of
    file (EOF).
    Output
    For each test case you must print the message: ‘Case #M: The maximum product is P.’, where
    M is the number of the test case, starting from 1, and P is the value of the maximum product. After
    each test case you must print a blank line.
    Sample Input
    3
    2 4 -3
    5
    2 5 -1 2 -1
    Sample Output
    Case #1: The maximum product is 8.
    Case #2: The maximum product is 20.

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <cmath>
    #include <string>
    using namespace std;
    int main()
    {
        int n,t=1,a[20],i,j;
        long long maxn,sum;
        while(cin >> n)
        {
            memset(a,0,sizeof(a));
            for(i=0;i<n;i++)
                cin >> a[i];
            for(i=0,maxn=0;i<n;i++)
            {
                for(j=i,sum=1;j<n;j++)
                {
                    sum *= a[j];//直接枚举起点到每个可能的终点的乘积
                    if(sum>maxn)
                        maxn = sum;
                }
            }
            cout << "Case #" << t++ << ": The maximum product is " << maxn << "." << endl;
            cout << endl;
        }
        return 0;
    }
    彼时当年少,莫负好时光。
  • 相关阅读:
    Python笔试题(递归)
    MYSQL经典面试题
    Linux常用命令
    HTTP协议相关面试题
    Flask面试题
    史上最全DVWA 笔记
    ssh root Permission denied
    odoo Reference 选择model 然后选择record
    定体, 定压, 定温, 绝热 Q E A 公式
    Vmware Bluetooth
  • 原文地址:https://www.cnblogs.com/l609929321/p/6900885.html
Copyright © 2011-2022 走看看