zoukankan      html  css  js  c++  java
  • 树形dp poj2342 Anniversary party * 求最大价值

    Description

    There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

    Input

    Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
    L K 
    It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
    0 0 

    Output

    Output should contain the maximal sum of guests' ratings.

    Sample Input

    7
    1
    1
    1
    1
    1
    1
    1
    1 3
    2 3
    6 4
    7 4
    4 5
    3 5
    0 0
    

    Sample Output

    5
     
    题意:有n个人,接下来n行是n个人的价值,再接下来n行给出l,k说的是l的上司是k,这里注意l与k是不能同时出现的
    思路:用dp数据来记录价值,开数组用下标记录去或者不去、

    则状态转移方程为:

    DP[i][1] += DP[j][0],

    DP[i][0] += max{DP[j][0],DP[j][1]};其中j为i的孩子节点。

    这样,从根节点r进行dfs,最后结果为max{DP[r][0],DP[r][1]}。

    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    #include<iostream>
    #include<vector>
    #include<queue>
    using namespace std;
    #define maxn 6005
    int dp[maxn][2],father[maxn];//dp[i][0]表示i不去,dp[i][1]表示i去
    int n;
    bool vis[maxn];
    void tree_dp(int node){
        vis[node] = true;
        for(int i=1;i<=n;i++){
            if(!vis[i] && father[i]==node){//i为node的下属
                tree_dp(i);//递归调用孩子结点,从叶子结点开始dp
                dp[node][1] += dp[i][0];//上司来,下属不来
                dp[node][0] += max(dp[i][0],dp[i][1]);//上司不来,下属来或不来
            }
        }
    }
    int main()
    {
        int f,c,root;
        while(~scanf("%d",&n)){
            memset(dp,0,sizeof(dp));
            memset(father,0,sizeof(father));
            memset(vis,0,sizeof(vis));
            for(int i=1;i<=n;i++){
                scanf("%d",&dp[i][1]);
            }
            root = 0;//记录父结点
            while(~scanf("%d%d",&c,&f)){
                if(!c || !f){
                    break;
                }
                father[c] = f;
                root = f;
            }
            while(father[root]){//查找父结点
                root = father[root];
            }
            tree_dp(root);
            cout << max(dp[root][0],dp[root][1]) << endl;
        }
        return 0;
    }
    彼时当年少,莫负好时光。
  • 相关阅读:
    设置DataGridView垂直滚动条
    在自定义MessageBox控件里添加键盘回车事件。
    通过访问注册表,表判断系统是否装excel
    让文本框里只能输入数字
    新晋菜鸟的错误
    jdbc连接数据库以及crud(简单易懂,本人亲测可用 有源代码和数据库)
    springboot 错误求解决
    maven 导包报错
    最短路径Dijkstra
    读写者问题
  • 原文地址:https://www.cnblogs.com/l609929321/p/7264143.html
Copyright © 2011-2022 走看看