zoukankan      html  css  js  c++  java
  • 杭电 HDU ACM Milk

    Milk

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 15697    Accepted Submission(s): 3947


    Problem Description
    Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

    Here are some rules:
    1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
    2. Ignatius drinks 200mL milk everyday.
    3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
    4. All the milk in the supermarket is just produced today.

    Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
    Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
     

    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.
     

    Output
    For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
     

    Sample Input
    2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
     

    Sample Output
    Mengniu Mengniu
    Hint
    In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.
     
    这个题目当时acm入门的时候,怎么也解决不了 。大水题一直搁置到现在。现在闲着没事干,a它分分秒。看着曾经提交的code,代码质量令今天的我非常是感概。

    又臭又长。而且回忆起曾经解这个题目时遇到的思路问题,感觉acm确实能给人带来思维上的强大进步,特别特别明显。

    想问题也想的非常清楚。事实上这个题目就是简单的把问题划分清楚就ok了,同一时候注意点儿细节。

    #include<iostream>
    #include<string>
    #include<algorithm>
    using namespace std;
    struct ls
    {
        string str;
        int mo;
        int ml;
        double rate;
    } gq[1000];
    bool cmp(ls co,ls cn)
    {
        return co.rate<cn.rate;
    }
    int main()
    {
        int T,n;
        cin>>T;
        while(T--)
        {
            cin>>n;
            for(int i=0; i<n; i++)
            {
                cin>>gq[i].str>>gq[i].mo>>gq[i].ml;
    
                if(gq[i].ml>=1200)
                    gq[i].rate=gq[i].mo/5;
                else if((gq[i].ml>=200))
                {
                    int x=(gq[i].ml)/200;
                    gq[i].rate=gq[i].mo/double(x*1.0);
                }
                else
                    gq[i].rate=-1;
            }
            double Min=0x1f1f1f1f;
            int k;
            for(int j=0; j<n; j++)
            {
                if(gq[j].rate!=-1)
                {
                    if(gq[j].rate<Min)
                    {
                        Min=gq[j].rate;
                        k=j;
                    }
                }
            }
            cout<<gq[k].str<<endl;
        }
        return 0;
    }
    /*
    2
    2
    Yili 10 500
    Mengniu 20 1000
    4
    Yili 10 600
    Mengniu 20 1000
    Guangming 1 199
    Yanpai 40 10000
    **/
    

  • 相关阅读:
    virtualbox使用相关问题
    mac os中的一些快捷键使用及基础软件安装
    U盘安装CentOS7
    Netbeans8下 Weblogic EJB案例
    Linux Weblogic 数据源 TimesTen配置
    JDBC操作TimesTen
    Red Hat TimesTen安装记录
    使用Protractor进行AngularJS e2e测试案例
    基于Karma和Jasmine的AngularJS测试
    protractor protractor.conf.js [launcher] Process exited with error code 1 undefined:1190
  • 原文地址:https://www.cnblogs.com/lcchuguo/p/5254704.html
Copyright © 2011-2022 走看看