zoukankan      html  css  js  c++  java
  • BST(二叉树搜索树)

    Description

    Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries.

    Input

    In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 231 - 1).

    Output

    There are N lines in total, the i-th of which contains the answer for the i-th query.

    Sample Input

    2
    8
    10
    

    Sample Output

    1 15
    9 11
    

    Hint

    #include <iostream>
    using namespace std;

    int main()
    {
     int T, x;
     scanf("%d", &T);
     while (T--)
     {
      scanf("%d", &x);
      printf("%d %d ", x-(x&(-x))+1, x+(x&(-x))-1);
     }
     return 0;
    }

  • 相关阅读:
    request和response概念用法
    servlet知识点
    Nginx的安装和配置文件详细说明
    Tomcat优化
    Tomcat安装和常见问题
    WEB服务器和tomcat介绍
    WEB技术相关入门知识点
    前期绑定和后期绑定
    1-4选择题
    1-3选择题
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387811.html
Copyright © 2011-2022 走看看