zoukankan      html  css  js  c++  java
  • Binary Tree(计算二叉树路径)

    Description

    Background 
    Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this: 
    • The root contains the pair (1, 1). 
    • If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

    Problem 
    Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right child?

    Input

    The first line contains the number of scenarios. 
    Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*109) that represent 
    a node (i, j). You can assume that this is a valid node in the binary tree described above.

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.

    Sample Input

    3
    42 1
    3 4
    17 73

    Sample Output

    Scenario #1:
    41 0
    
    Scenario #2:
    2 1
    
    Scenario #3:
    4 6

    超时

    #include <iostream>
    using namespace  std;
    int main()
    {int t,i;
    cin>>t;
    for(i=1;i<=t;i++)
    {int r=0,l=0,m,n;
    cin>>m>>n;
    while(m!=1||n!=1)
    {if(m>n)
    {l++;m=m-n;}
    
    if(m<n)
    {r++;n=n-m;}
    
    }
    
    
    
    cout<<"Scenario #"<<i<<":"<<endl;
    cout<<l<<" "<<r<<endl;
    
    }
    
    	return 0;}

    ac

    #include <iostream>
    using namespace  std;
    int main()
    {int t,i;
    cin>>t;
    for(i=1;i<=t;i++)
    {int r=0,l=0,m,n;
    cin>>m>>n;
    while(m!=1||n!=1)
    {if(m>n)
    {if(m%n)
    {
     l+= m/n;
     m = m%n;      
    }
    else
    {
     l+= (m/n-1);
     m=1;
    }        


    }

    if(m<n)
    {if(n%m)
    {
     r += n/m;      
     n = n%m;  
    }
    else
    {
     r+= (n/m-1);
     n = 1;
    }      


    }

    }

    cout<<"Scenario #"<<i<<":"<<endl;
    cout<<l<<" "<<r<<endl<<endl;

    }

    return 0;}

  • 相关阅读:
    一个家伙与javascript的故事
    Quick-Cocos2dx 3.3中关于cc.ScaleTo动作不能得到预期效果
    vim的youcompleteme插件安装过程
    MAC OS上编译mod_wsgi不成功问题的解决办法
    Quick-Cocos2dx中对一个Node的所有成员应用灰色滤镜
    Sublime text安装各种插件
    Quick-Cocos2dx 3.3编译android版本
    bootstrap轮播,播放到最后一张图片的时候,就不正确了。
    Apache2.2 + php5配置
    swift 笔记
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387814.html
Copyright © 2011-2022 走看看