zoukankan      html  css  js  c++  java
  • Binary Tree(计算二叉树路径)

    Description

    Background 
    Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this: 
    • The root contains the pair (1, 1). 
    • If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

    Problem 
    Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right child?

    Input

    The first line contains the number of scenarios. 
    Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*109) that represent 
    a node (i, j). You can assume that this is a valid node in the binary tree described above.

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.

    Sample Input

    3
    42 1
    3 4
    17 73

    Sample Output

    Scenario #1:
    41 0
    
    Scenario #2:
    2 1
    
    Scenario #3:
    4 6

    超时

    #include <iostream>
    using namespace  std;
    int main()
    {int t,i;
    cin>>t;
    for(i=1;i<=t;i++)
    {int r=0,l=0,m,n;
    cin>>m>>n;
    while(m!=1||n!=1)
    {if(m>n)
    {l++;m=m-n;}
    
    if(m<n)
    {r++;n=n-m;}
    
    }
    
    
    
    cout<<"Scenario #"<<i<<":"<<endl;
    cout<<l<<" "<<r<<endl;
    
    }
    
    	return 0;}

    ac

    #include <iostream>
    using namespace  std;
    int main()
    {int t,i;
    cin>>t;
    for(i=1;i<=t;i++)
    {int r=0,l=0,m,n;
    cin>>m>>n;
    while(m!=1||n!=1)
    {if(m>n)
    {if(m%n)
    {
     l+= m/n;
     m = m%n;      
    }
    else
    {
     l+= (m/n-1);
     m=1;
    }        


    }

    if(m<n)
    {if(n%m)
    {
     r += n/m;      
     n = n%m;  
    }
    else
    {
     r+= (n/m-1);
     n = 1;
    }      


    }

    }

    cout<<"Scenario #"<<i<<":"<<endl;
    cout<<l<<" "<<r<<endl<<endl;

    }

    return 0;}

  • 相关阅读:
    apache、php隐藏http头部版本信息的实现方法
    CentOs 设置静态IP 方法
    PHP如何判断远程图片文件是否存在
    linux删除乱码文件
    Linux基础学习1
    C#——继承
    解决简体输出乱码问题
    简单的Tuple声明和输出
    懒汉式与饿汉式的区别
    Java 反射
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387814.html
Copyright © 2011-2022 走看看