zoukankan      html  css  js  c++  java
  • Corporative Network

    A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon, for amelioration of the services, the corporation started to collect some enterprises in clusters, each of them served by a single computing and telecommunication center as follow. The corporation chose one of the existing centers I (serving the cluster A) and one of the enterprises J in some cluster B (not necessarily the center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I – J|(mod 1000). In such a way the two old clusters are joined in a new cluster, served by the center of the old cluster B. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving center could be changed and the end users would like to know what is the new length. Write a program to keep trace of the changes in the organization of the network that is able in each moment to answer the questions of the users.


    Input

    Your program has to be ready to solve more than one test case. The first line of the input file will contains only the number T of the test cases. Each test will start with the number N of enterprises (5≤N≤20000). Then some number of lines (no more than 200000) will follow with one of the commands:
    E I – asking the length of the path from the enterprise I to its serving center in the moment;
    I I J – informing that the serving center I is linked to the enterprise J.
    The test case finishes with a line containing the word O. The I commands are less than N.

    Output

    The output should contain as many lines as the number of E commands in all test cases with a single number each – the asked sum of length of lines connecting the corresponding enterprise with its serving center.

    Sample Input

    1
    4
    E 3
    I 3 1
    E 3
    I 1 2
    E 3
    I 2 4
    E 3
    O
    Sample Output

    0
    2
    3
    5

    #include <iostream>
    #include <algorithm>
    using namespace std;
    const int maxn=20000+10;
    int pa[maxn],d[maxn];
    int find(int x)
    {if(pa[x]!=x)
    {int root=find(pa[x]);
    d[x]+=d[pa[x]];
    return pa[x]=root;

    }else return x;

    }
    int main()
    {int t;
    cin>>t;
    while(t--)
        {int n,i,v,u;
        char c[9];
        cin>>n;
        for(i=1;i<=n;i++){pa[i]=i;d[i]=0;}
            while(cin>>c&&c[0]!='O')
        {if(c[0]=='E'){cin>>u;find(u);cout<<d[u]<<endl;}
        if(c[0]=='I'){cin>>u>>v;pa[u]=v;d[u]=abs(u-v)%1000;}

        }

        }
        return 0;
    }

  • 相关阅读:
    二.线性表
    一.绪论
    托管服务器代码
    jquery easyui DataGrid 数据表格 属性
    用socket 模拟http请求
    struct和class的相同点与不同点
    c++中的基本数据类型
    当函数返回一个局部变量的指针问题,内存是否被释放
    Python首先生成包含1000个随机字符的字符串,然后统计每个字符的出现次数。(使用字典)
    浅谈结构体字节的求法
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387822.html
Copyright © 2011-2022 走看看