zoukankan      html  css  js  c++  java
  • hdoj_1394Minimum Inversion Number

    Minimum Inversion Number

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 6642    Accepted Submission(s): 4051


    Problem Description
    The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

    For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

    a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
    a2, a3, ..., an, a1 (where m = 1)
    a3, a4, ..., an, a1, a2 (where m = 2)
    ...
    an, a1, a2, ..., an-1 (where m = n-1)

    You are asked to write a program to find the minimum inversion number out of the above sequences.
     

    Input
    The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
     

    Output
    For each case, output the minimum inversion number on a single line.
     

    Sample Input
    10 1 3 6 9 0 8 5 7 4 2
     

    Sample Output
    16

    #include<iostream>
    #include <cstring>
    #include <cstdio>
    #include <algorithm>
    using namespace std;
    #pragma warning(disable : 4996)
    const int MAXN = 5005;
    int tree[MAXN];
    int num[MAXN];
    int n;
    
    int lowbit(int x)
    {
    	return x & (-x); 
    }
    
    int getsum(int pos)
    {
    	int sum = 0;
    	while (pos > 0)
    	{
    		sum += tree[pos];
    		pos -= lowbit(pos);
    	}
    	return sum;
    }
    
    void update(int pos, int value)
    {
    	while (pos <= n)
    	{
    		tree[pos] += value;
    		pos += lowbit(pos);
    	}
    }
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	int sum, ans;
    	while (scanf("%d", &n) != EOF)
    	{
    		sum = 0;
    		memset(tree, 0, sizeof(tree));
    		for(int i = 1; i <= n; i++)
    		{
    			scanf("%d", &num[i]);
    			update(num[i] + 1, 1);
    			sum += getsum(n) - getsum(num[i] + 1);
    			//sum += i - getsum(num[i] + 1);
    		}
    		//cout << sum << endl;
    		ans = sum;
    		for (int i = 1; i <= n; i++)
    		{
    			sum = sum - 2 * num[i] + n - 1;
    			if(sum < ans)
    			{
    				ans = sum;
    			}
    		}
    		printf("%d\n", ans);
    	}
    	return 0;
    }


  • 相关阅读:
    Vue 框架怎么实现对象和数组的监听?
    能说下 vue-router 中常用的 hash 和 history 路由模式实现原理吗?
    vue-router 路由模式有几种?
    Vue 组件间通信有哪几种方式?
    v-model 的原理?
    华硕笔记本修复
    linux下制作u盘启动盘
    virtualbox不能启动虚拟机
    ubuntu14.04建立wifi热点
    git中文文件名和中文目录显示乱码
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835042.html
Copyright © 2011-2022 走看看