zoukankan      html  css  js  c++  java
  • poj_2031Building a Space Station(最小生成树)

    Building a Space Station
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 3397   Accepted: 1745

    Description

    You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task. 
    The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible. 

    All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively. 

    You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors. 

    You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect. 

    Input

    The input consists of multiple data sets. Each data set is given in the following format. 


    x1 y1 z1 r1 
    x2 y2 z2 r2 
    ... 
    xn yn zn rn 

    The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100. 

    The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character. 

    Each of x, y, z and r is positive and is less than 100.0. 

    The end of the input is indicated by a line containing a zero. 

    Output

    For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001. 

    Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000. 

    Sample Input

    3
    10.000 10.000 50.000 10.000
    40.000 10.000 50.000 10.000
    40.000 40.000 50.000 10.000
    2
    30.000 30.000 30.000 20.000
    40.000 40.000 40.000 20.000
    5
    5.729 15.143 3.996 25.837
    6.013 14.372 4.818 10.671
    80.115 63.292 84.477 15.120
    64.095 80.924 70.029 14.881
    39.472 85.116 71.369 5.553
    0

    Sample Output

    20.000
    0.000
    73.834
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cmath>
    using namespace std;
    #pragma warning(disable : 4996)
    #define MAX 20000
    #define INF 1e-8
    
    typedef struct Point
    {
    	double x, y, z, r;
    }Point;
    
    typedef struct edge
    {
    	int x, y;
    	double dis;
    }edge;
    
    Point point[MAX];
    edge e[MAX];
    int father[MAX], ranks[MAX];
    
    bool cmp(edge a,edge b)
    {
    	return a.dis < b.dis;
    }
    
    double dis(int i,int j)
    {
    
    	double d;  
    	d = sqrt( (point[i].x-point[j].x)*(point[i].x-point[j].x) +   
    		(point[i].y-point[j].y)*(point[i].y-point[j].y) +   
    		(point[i].z-point[j].z)*(point[i].z-point[j].z) ) - point[i].r - point[j].r;  
    	if(d < INF) d = 0;
    	return d;
    }  
    
    void Make_Set(int n)
    {
    	for(int i = 1; i <= n; i++)
    	{
    		father[i] = i;
    		ranks[i] = 0;
    	}
    }
    
    int Find_Set(int x)
    {
    	if(x != father[x])
    		father[x] = Find_Set(father[x]);
    	return father[x];
    }
    
    void Merge_Set(int x, int y)
    {
    	x = Find_Set(x);
    	y = Find_Set(y);
    	if(x == y) return;
    	if(ranks[x] > ranks[y])
    	{
    		father[y] = x;
    	}
    	else if(ranks[x] < ranks[y])
    	{
    		father[x] = y;
    	}
    	else 
    	{
    		ranks[y]++;
    		father[x] = y;
    	}
    }
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	int n, count;
    	double ans;
    	while (scanf("%d", &n) != EOF)
    	{
    		if(n == 0)
    		{
    			break;
    		}
    		Make_Set(n);
    		for(int i = 1; i <= n; i++)
    		{
    			scanf("%lf %lf %lf %lf", &point[i].x, &point[i].y, &point[i].z, &point[i].r);
    		}
    		count = 0;
    		for (int i = 1; i <= n; i++)
    		{
    			for(int j = i + 1; j <= n; j++)
    			{
    				e[count].x = i;
    				e[count].y = j;
    				e[count++].dis = max(0.0, dis(i, j));
    			}
    		}
    		sort(e, e + count, cmp);
    		ans = 0.0;
    		for (int i = 0; i < count; i++)
    		{
    			if(Find_Set(e[i].x) != Find_Set(e[i].y))
    			{
    				ans += e[i].dis;
    				Merge_Set(e[i].x, e[i].y);
    			}
    		}
    		printf("%.3lf\n", ans);
    	}
    	return 0;
    }



  • 相关阅读:
    手机游戏怎么独占世界手游鳌头
    游戏开发商是如何做到每日进帐410万美元的?
    [手游新项目历程]-48-svn分支开发与主干合并
    三国武将所带兵种
    Supercell:靠两款手游如何做到30亿美金市值?
    理财投资这需要知道的50个真相
    [手游新项目历程]-49-性能分析
    [手游新项目历程]-50-Mysql的大字段问题(数据库执行错误: Error=1118, Reason=Row size too large (> 8126))
    三国杀
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835067.html
Copyright © 2011-2022 走看看