zoukankan      html  css  js  c++  java
  • hdoj_1162Eddy's picture(最小生成树)

    Eddy's picture

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 4953    Accepted Submission(s): 2448


    Problem Description
    Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
    Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
     

    Input
    The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 

    Input contains multiple test cases. Process to the end of file.
     

    Output
    Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 
     

    Sample Input
    3 1.0 1.0 2.0 2.0 2.0 4.0
     

    Sample Output
    3.41
    最小生成树,

    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cmath>
    using namespace std;
    #pragma warning(disable : 4996)
    #define MAX 10000
    typedef struct edge
    {
    	int x, y;
    	double w;
    }edge;
    
    edge e[MAX];
    int father[MAX], ranks[MAX];
    
    bool cmp(edge a,edge b)
    {
    	return a.w < b.w;
    }
    
    void Make_Set(int n)
    {
    	for(int i = 1; i <= n; i++)
    	{
    		father[i] = i;
    		ranks[i] = 0;
    	}
    }
    
    int Find_Set(int x)
    {
    	if(x != father[x])
    		father[x] = Find_Set(father[x]);
    	return father[x];
    }
    
    void Merge_Set(int x, int y)
    {
    	x = Find_Set(x);
    	y = Find_Set(y);
    	if(x == y) return;
    	if(ranks[x] > ranks[y])
    	{
    		father[y] = x;
    	}
    	else if(ranks[x] < ranks[y])
    	{
    		father[x] = y;
    	}
    	else 
    	{
    		ranks[y]++;
    		father[x] = y;
    	}
    }
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	double point[MAX][2] = {0.0};
    	int n, count;
    	double len;
    	while (scanf("%d", &n) != EOF)
    	{
    		count = 0;
    		for(int i = 1; i <= n; i++)
    		{
    			scanf("%lf %lf", &point[i][0], &point[i][1]);
    		}
    		for(int i = 1; i <= n; i++)
    		{
    			for(int j = i + 1; j <= n; j++)
    			{
    				len = sqrt((point[i][0] - point[j][0]) * (point[i][0] - point[j][0]) + (point[i][1] - point[j][1]) * (point[i][1] - point[j][1]));
    				if(len > 0)
    				{
    					e[count].x = i;
    					e[count].y = j;
    					e[count++].w = len;
    				}
    			}
    		}
    		Make_Set(count - 1);
    		sort(e, e + count , cmp);
    		/*for(int i = 0; i < count; i++)
    		{
    			cout << e[i].x << " " << e[i].y << " " << e[i].w << endl;
    		}*/
    		double sum = 0.0;
    		for (int i = 0; i < count; i++)
    		{
    			int x = Find_Set(e[i].x);
    			int y = Find_Set(e[i].y);
    			if(x != y)
    			{
    				Merge_Set(e[i].x, e[i].y);
    				sum += e[i].w;
    			}
    		}
    		printf("%.2lf\n", sum);
    	}
    	return 0;
    }
    


  • 相关阅读:
    使用OwnCloud建立属于自己私有的云存储网盘
    Linux服务器学习----tomcat 服务配置实验报告(一)
    Linux服务器学习----haproxy+keepalived
    Docker容器版Jumpserver堡垒机搭建部署方法附Redis
    Dokcer的一些命令:
    Docker安装prometheus监控
    CentOS7安装Docker
    用Dockerfile来制作contos镜像
    CentOS7中服务器网卡配置——配置静态IP
    CentOS7中搭建rabbitmq单机
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835071.html
Copyright © 2011-2022 走看看