zoukankan      html  css  js  c++  java
  • poj_1611The Suspects

    The Suspects
    Time Limit: 1000MS   Memory Limit: 20000K
    Total Submissions: 17471   Accepted: 8426

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
    Once a member in a group is a suspect, all members in the group are suspects.
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1
    #include<iostream>
    #include<vector>
    #include<algorithm>
    using namespace std;
    #define MAX 30005
    int father[MAX],ranks[MAX];
    
    void Make_Set(int n)
    {
    	for(int i = 0;i < n; i++)
    	{
    		father[i] = i;
    		ranks[i] = 0;
    	}
    }
    
    int Find_Set(int x)
    {
    	if(x != father[x])
    	{
    		father[x] = Find_Set(father[x]);//路径压缩
    	}
    	return father[x];
    }
    
    void Merge_Set(int x,int y)
    {
    	x = Find_Set(x);
    	y = Find_Set(y);
    	if(x == y) return;
    	if(ranks[x] > ranks[y])
    	{
    		father[y] = x;
    	}
    	else if(ranks[x] < ranks[y])
    	{
    		father[x] = y;
    	}
    	else
    	{
    		ranks[y]++;
    		father[x] = y;
    	}
    }
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	vector<int>temp;
    	int n, m, t, stu, y, sum;
    	while(cin >> n >> m)
    	{
    		sum = 0;
    		if(n == 0 && m == 0) break;
    		Make_Set(n);
    		while(m--)
    		{
    			cin >> t >> stu;
    			temp.push_back(stu);
    			for(int i = 1; i < t; i++)
    			{
    				cin >> y;
    				temp.push_back(y);
    				Merge_Set(stu,y);
    				stu = y;
    			}
    		}
    		sort(temp.begin(), temp.end());
    		temp.erase(unique(temp.begin(), temp.end()), temp.end());
    		int x = Find_Set(0);
    		for(int i = 0; i < temp.size(); i++)
    		{
    			if(x == Find_Set(temp[i]))
    			{
    				sum++;
    			}
    			if(sum == 0)
    			{
    				sum++;
    			}
    		}
    		cout<< sum <<endl;
    	}
    	return 0;
    }


     

  • 相关阅读:
    PHP excel读取excel文件转换为数组
    PHP输出xls文件
    proxy_redirect参数的作用
    nginx反向代理批量实现https协议访问
    用lua nginx module搭建一个二维码
    canvas操作图片,进行面板画图,旋转等
    线性表
    什么是闭包
    简单注解扫描的思考
    编写自己的validate校验框架原理(转)
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835081.html
Copyright © 2011-2022 走看看