zoukankan      html  css  js  c++  java
  • poj_2250Compromise

    Compromise
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 5074   Accepted: 2314   Special Judge

    Description

    In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do. 

    Therefore the German government requires a program for the following task: 
    Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind). 

    Your country needs this program, so your job is to write it for us.

    Input

    The input will contain several test cases. 
    Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'. 
    Input is terminated by end of file.

    Output

    For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

    Sample Input

    die einkommen der landwirte
    sind fuer die abgeordneten ein buch mit sieben siegeln
    um dem abzuhelfen
    muessen dringend alle subventionsgesetze verbessert werden
    #
    die steuern auf vermoegen und einkommen
    sollten nach meinung der abgeordneten
    nachdruecklich erhoben werden
    dazu muessen die kontrollbefugnisse der finanzbehoerden
    dringend verbessert werden
    #
    

    Sample Output

    die einkommen der abgeordneten muessen dringend verbessert werden
    
    
    最长公共子序列。用一个flag数组记录,输出时递归。
    #include <iostream>
    #include <string>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    string str[105];
    string dest[105];
    int dp[105][105];
    int flag[105][105];
    string result[105];
    int num;
    
    int LCS(int x, int y)
    {
    	memset(dp,0,sizeof(dp));
    	memset(flag,-1,sizeof(flag));
    	int i,j;
    	for(i=1; i<=x; i++)
    	{
    		for(j=1; j <= y; j++)
    		{
    			if(dest[i-1] == str[j-1])
    			{
    				dp[i][j] = dp[i-1][j-1] + 1;
    				flag[i][j] = 0;
    			}
    			else if(dp[i-1][j] >= dp[i][j-1])
    			{
    				dp[i][j] = dp[i-1][j];
    				flag[i][j] = 1;
    			}
    			else
    			{
    				dp[i][j] = dp[i][j-1];
    				flag[i][j] = 2;
    			}
    		}
    	}
    	return dp[x][y];
    }
    
    void ShowLCS(int x, int y)
    {
    	if(x == 0 || y == 0) return;
    	if(flag[x][y] == 0)
    	{
    		ShowLCS(x-1,y-1);
    		result[num++] = dest[x-1];
    		//cout<<dest[x-1]<<" ";
    	}
    	else if(flag[x][y] == 1)
    	{
    		ShowLCS(x-1,y);
    	}
    	else
    	{
    		ShowLCS(x,y-1);
    	}
    }
    
    int main()
    {
    	freopen("in.txt","r",stdin);
    	string s;
    	int dest_len,str_len,i;
    	bool ans = false;
    	while(cin >> s)
    	{
    		memset(dest,0,sizeof(dest));
    		memset(str,0,sizeof(str));
    		dest_len = 0;
    		if(s != "#")
    		{
    			dest[dest_len++] = s;
    			ans = false;
    			while(cin >> s)
    			{
    				if(s == "#") 
    				{
    					str_len = 0;
    					while(cin >> s)
    					{
    						if(s == "#")
    						{
    							ans = true;
    							break;
    						}
    						str[str_len++] = s;
    					}
    				}
    				else
    				{
    					dest[dest_len++] = s;
    				}
    				if(ans == true) break;
    			}
    		}
    		int ant = LCS(dest_len,str_len);
    		num = 0;
    		ShowLCS(dest_len,str_len);
    		//cout<<ant<<endl;
    		for(i=0;i<num-1;i++)
    			cout<<result[i]<<" ";
    		cout<<result[num-1]<<endl;
    	}
    }


  • 相关阅读:
    【转】Centos yum 换源
    centos7下使用yum安装mysql
    【转】简易smtp调用类
    【转】Beanstalkd 队列简易使用
    【转】mysql 拖库写库用法
    【转】scp 命令格式
    【转】mac os 安装php
    pip 国内源 gem 国内源
    【转】25个必须记住的SSH命令
    NHibernate 有好几种数据库查询方式
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835272.html
Copyright © 2011-2022 走看看