zoukankan      html  css  js  c++  java
  • poj_3636Nested Dolls

    Nested Dolls
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7225   Accepted: 1932

    Description

    Dilworth is the world's most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h= if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?

    Input

    On the first line of input is a single positive integer 1 ≤ t ≤ 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 ≤ m ≤ 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1h1,w2h2, ... ,wmhm, where wi is the width and hi is the height of doll number i. 1 ≤ wihi ≤ 10000 for all i.

    Output

    For each test case there should be one line of output containing the minimum number of nested dolls possible.

    Sample Input

    4
    3
    20 30 40 50 30 40
    4
    20 30 10 10 30 20 40 50
    3
    10 30 20 20 30 10
    4
    10 10 20 30 40 50 39 51

    Sample Output

    1
    2
    3
    2
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    
    struct Point{
    	int w;
    	int h;
    }array[20005];
    
    bool cmp(Point a, Point b)
    {
    	if(a.w==b.w) return a.h < b.h;
    	else return a.w > b.w;
    }
    
    int arr[20005];
    int dp[20005];
    int n;
    
    int bSearch(int num, int k)  
    {  
    	int low=1, high=k;  
    	while(low<=high)  
    	{  
    		int mid=(low+high)/2;  
    		if(num>=dp[mid])  
    			low=mid+1;  
    		else   
    			high=mid-1;  
    	}  
    	return low;  
    }  
    
    int LIS()
    {
    	int k = 1;
    	dp[1] = arr[1];
    	for(int i=2; i<=n; ++i)
    	{
    		if(arr[i]>=dp[k])
    			dp[++k] = arr[i];
    		else
    		{
    			int pos = bSearch(arr[i], k);
    			dp[pos] = arr[i];
    		}
    	}
    	return k;
    }
    
    int main()
    {
    	freopen("in.txt","r",stdin);
    	int t;
    	scanf("%d",&t);
    	while(t--)
    	{
    		memset(array,0,sizeof(array));
    		scanf("%d",&n);
    		for(int i=1;i<=n;i++)
    		{
    			scanf("%d %d",&array[i].w,&array[i].h);
    		}
    		sort(array+1,array+n+1,cmp);
    		for(int i=1;i<=n;i++)
    			arr[i] = array[i].h;
    		printf("%d\n",LIS());
    	}
    }


  • 相关阅读:
    Python的一些小技巧
    Python连接sqlite3数据库
    闭包和toString方法的使用
    webpack(10) webpack扩展(插件. loader)
    webpack(9) 配置文件
    webpack(8) plugin
    webpack(7) 样式处理和图片处理之手写loader
    webpack(6) loader
    webpack(5)入口和出口
    webpack(4)编译过程分析
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835295.html
Copyright © 2011-2022 走看看