zoukankan      html  css  js  c++  java
  • UVa 694 The Collatz Sequence

      The Collatz Sequence 

    Time limit: 3.000 seconds

    An algorithm given by Lothar Collatz produces sequences of integers, and is described as follows:

    Step 1:
    Choose an arbitrary positive integer A as the first item in the sequence.
    Step 2:
    If A = 1 then stop.
    Step 3:
    If A is even, then replace A by A / 2 and go to step 2.
    Step 4:
    If A is odd, then replace A by 3 * A + 1 and go to step 2.

    It has been shown that this algorithm will always stop (in step 2) for initial values of A as large as 109, but some values of A encountered in the sequence may exceed the size of an integer on many computers. In this problem we want to determine the length of the sequence that includes all values produced until either the algorithm stops (in step 2), or a value larger than some specified limit would be produced (in step 4).

     

    Input 

    The input for this problem consists of multiple test cases. For each case, the input contains a single line with two positive integers, the first giving the initial value of A (for step 1) and the second giving L, the limiting value for terms in the sequence. Neither of these, A or L, is larger than 2,147,483,647 (the largest value that can be stored in a 32-bit signed integer). The initial value of A is always less than L. A line that contains two negative integers follows the last case.

     

    Output 

    For each input case display the case number (sequentially numbered starting with 1), a colon, the initial value for A, the limiting value L, and the number of terms computed.

     

    Sample Input 

     

     3 100
     34 100
     75 250
     27 2147483647
     101 304
     101 303
     -1 -1
    

     

    Sample Output 

     Case 1: A = 3, limit = 100, number of terms = 8
     Case 2: A = 34, limit = 100, number of terms = 14
     Case 3: A = 75, limit = 250, number of terms = 3
     Case 4: A = 27, limit = 2147483647, number of terms = 112
     Case 5: A = 101, limit = 304, number of terms = 26
     Case 6: A = 101, limit = 303, number of terms = 1
    

     

     


    Miguel Revilla 
    2000-08-14
     
    #include<stdio.h>
    int collatz(long A, long limit, long &terms)
    {
        unsigned long long a = 3*A+1;
        ++terms;
        if(A == 1)     return 0;
        else if(A%2 == 0) collatz(A/2, limit, terms);
        else 
        {
            if(a > limit) return 0;
            else collatz(A*3+1, limit, terms);
        }
    }
    
    int main()
    {
        long A, limit, terms, count = 0;
        while((scanf("%ld%ld", &A, &limit) != EOF) && A >= 0 && limit >=0)
        {
            terms = 0;
            collatz(A, limit, terms);
            printf("Case %ld: A = %ld, limit = %ld, number of terms = %ld\n", ++count, A, limit, terms);
        }
        return 0;
    }

    解题报告:

    1A,主要是看是否掌握递归简单的思想,代码编写的过程出现了很多的小错误,列举说:求模写成了求商整数,即把%写成了/,二是输出的时候少

    加一个变量,会开始用断言(assert),不过代码中出现的错误还是通过printf出中间值找出来的

  • 相关阅读:
    uniq命令
    全局滚动条样式美化
    感受一下Java乱码出现就知道怎么解决Java乱码了
    用于注解解析的工具类
    迅为i.MX8MM开发板资料更新啦!Linux安卓9.0工业核心板
    迅为-IMX6Q开发板Buildroot文件系统nfs测试
    进步一点点丨迅为4412开发板Linux内核开发基础
    迅为RK3399开发板运行第一个Android程序
    每天学习一点丨借助U盘或TF卡拷贝程序到迅为IMX6ULL开发板上(二)
    资料完整丨i.MX6Q开发板ARM恩智浦工业级linux安卓系统迅为iMX6Q/DL Plus板
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2743003.html
Copyright © 2011-2022 走看看