zoukankan      html  css  js  c++  java
  • Uva 408 Uniform Generator

     Uniform Generator 

    Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

    displaymath29

    where `` tex2html_wrap_inline31 " is the modulus operator.

    Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

    For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the sameseed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 andMOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

    If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

    Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

    Input

    Each line of input will contain a pair of integers for STEP and MOD in that order ( tex2html_wrap_inline77 ).

    Output

    For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either ``Good Choice" or ``Bad Choice" left-justified starting in column 25. The ``Good Choice" message should be printed when the selection of STEP andMOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message ``Bad Choice". After each output test set, your program should print exactly one blank line.

    Sample Input

    3 5
    15 20
    63923 99999

    Sample Output

             3         5    Good Choice
    
            15        20    Bad Choice
    
         63923     99999    Good Choice
    
    #include<stdio.h>
    #include<string.h>
    #define MAXN 10000000
    int cycle[MAXN];
    int main()
    {
        int i, temp, step, mod, cnt;
        while(scanf("%d%d", &step, &mod) != EOF)
        {
            for(i=0; i<mod; ++i) cycle[i] = 0;
            temp = cnt = 0;
            for(; cnt<mod; ++cnt)
            {
                cycle[temp] = 1;
                temp = (temp + step) % mod;
            }
            for(i=0; i<mod && cycle[i] == 1; i++);
            printf("%10d%10d    ", step, mod);
            if(i>=mod) printf("Good Choice\n\n");
            else printf("Bad Choice\n\n");
        }
        
        return 0;
    }

     解题报告:

    算是一种暴力吧,将所有得到的值放到数组里,然后再遍历判断是否符合题目的要求

  • 相关阅读:
    vs2005 enable your debug
    暑假的安排
    session
    我所看过的电影——不断更新中……
    symbian
    CUDA学习。。。visual assist 扩展
    MySQL密码修改
    fcitx in Fedora
    LDAP身份验证
    mysql自增auto_increment删除记录
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2952196.html
Copyright © 2011-2022 走看看