zoukankan      html  css  js  c++  java
  • POJ 2109 Power of Cryptography(数论)

    Power of Cryptography
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 12219   Accepted: 6251

    Description

    Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
    This problem involves the efficient computation of integer roots of numbers. 
    Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is what your program must find).

    Input

    The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn = p.

    Output

    For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

    Sample Input

    2 16
    3 27
    7 4357186184021382204544

    Sample Output

    4
    3
    1234

    Source

    解题思路:训练计划上说这是一道贪心的题目,想了好久也没有想出办法,就去Discuss看了看,结果用下面的方法就能AC,因为kn = p,所求的是n,k = p的1/n的次方;
    代码如下:
    #include <iostream>
    #include <cstdio>
    #include <cmath>
    using namespace std;
    int main()
    {
    double n, p;
    while (scanf("%lf%lf", &n, &p) != EOF)
    {
    printf("%.0lf\n", pow(p, 1.0 / n));
    }
    return 0;
    }
  • 相关阅读:
    2019年8月下旬
    2019年8月上旬
    2019年7月 vue专题
    2019年7月上
    mysql安装 demo [linux centos7] [5.7.26]
    记一个日志冲突——管中窥豹[java混乱的日志体系]
    Mybatis-Generator demo
    dubbo doc入门文档
    springBoot+mysql+mybatis demo [基本配置] [遇到的问题]
    nginx安装demo
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2365411.html
Copyright © 2011-2022 走看看