zoukankan      html  css  js  c++  java
  • POJ 1125 Stockbroker Grapevine(最短路径Floyd算法)

    Stockbroker Grapevine

    Time Limit: 1000MS

     

    Memory Limit: 10000K

    Total Submissions: 19042

     

    Accepted: 10287

    Description

    Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

    Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

    Input

    Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

    Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

    Output

    For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
    It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

    Sample Input

    3

    2 2 4 3 5

    2 1 2 3 6

    2 1 2 2 2

    5

    3 4 4 2 8 5 3

    1 5 8

    4 1 6 4 10 2 7 5 2

    0

    2 2 5 1 5

    0

    Sample Output

    3 2

    3 10

    Source

    Southern African 2001

     解题报告:这道题是求有向图的最短路径,但不是直接求,把每点之间的最短路径都得求出来之后,遍历一次选出最短路径源点,再从这个源点选出最长的路径,因为得求全部的用Floyd()算法最好了!

    代码如下:

    #include <iostream>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    const int N = 110;
    const int INF = 99999999;
    int map[N][N], n, m;
    void Floyd()
    {
    int i, j, k;
    for (k = 1; k <= n; ++k)
    {
    for (i = 1; i <= n; ++i)
    {
    for (j= 1; j <= n; ++j)
    {
    if(map[i][j] > map[i][k] + map[k][j])
    {
    map[i][j] = map[i][k] + map[k][j];
    }
    }
    }
    }
    }
    int main()
    {
    int i, j, p, v, min, position, max ;
    while (scanf("%d", &n) != EOF && n)
    {
    memset(map, 0, sizeof(map));
    for (i = 0; i <= n; ++i)
    {
    for (j = 0; j <= n; ++j)
    {
    if(i != j)
    {
    map[i][j] = INF;//初始化相当于每点间的距离是无穷
    }
    }
    }
    for (i = 1; i <= n; ++i)
    {
    scanf("%d", &m);
    for (j = 1; j <= m; ++j)
    {
    scanf("%d%d",&p, &v);
    map[i][p] = v;
    }
    }
    Floyd();
    min = INF;//min最终是存储的是以i(1 --n)作为出发点时,到达其它点中的最长距离中的最短距离
    for (i = 1; i <= n; ++i)
    {
    max = 0;//每次循环的时候重新赋值
    for (j = 1; j<= n; ++j)//找出和 i 相连接的最长距离
    {
    if (map[i][j] > max)
    {
    max = map[i][j];
    }
    }
    if(max < min)
    {
    min = max;
    position = i;
    }
    }
    if (min == INF)//不相通
    {
    printf("disjoint\n");
    }
    else
    {
    printf("%d %d\n", position, min);
    }
    }
    return 0;
    }



  • 相关阅读:
    「题解」:毛一琛/$cow$ $subsets$
    「题解」:$e$
    「题解」:$d$
    「题解」:$Simple$
    「题解」:$Game$
    「题解」:砖块
    「题解」:天才绅士少女助手克里斯蒂娜
    约瑟夫问题小结
    「题解」:[loj2763][JOI2013]现代豪宅
    20190812
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2384247.html
Copyright © 2011-2022 走看看