zoukankan      html  css  js  c++  java
  • POJ 1260:Pearls 珍珠DP

    Pearls
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 7947   Accepted: 3949

    Description

    In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class. 
    Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl. 
    Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the 
    prices remain the same. 
    For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro. 
    The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program. 

    Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one. 

    Input

    The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000). 
    The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers. 

    Output

    For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list. 

    Sample Input

    2
    2
    100 1
    100 2
    3
    1 10
    1 11
    100 12

    Sample Output

    330
    1344

    题意是为了防止有顾客只买一种珍珠的一个,有一个购买规则即买一种珍珠的价钱为(购买的数量+10)*购买的单价,现给出要购买的珍珠的价钱和数量,在可以提高珍珠质量的前提下,求最小购买价格。

    这个题一开始做成了贪心。。。结果想了一想贪心在这题上是不对的,可能前两种归一起,后两种归一起。

    其实有一点是肯定的,就是如果第i种珍珠归到第j种珍珠上(当然i<j),那么第i+1,i+2...j-1种珍珠也一定归到了第j种珍珠上,所以DP的思路也就有了。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    int dp1[105];//前i种珍珠的数量
    int sum[105];
    int dp2[105];//搞到第i种珍珠为止,花的钱
    int value[105];//第i中珍珠的单价
    int num;
    
    int main()
    {
    	//freopen("i.txt","r",stdin);
    	//freopen("o.txt","w",stdout);
    
    	int Test,i,j;
    	cin>>Test;
    	
    	while(Test--)
    	{
    		cin>>num;
    
    		memset(dp1,0,sizeof(dp1));
    		memset(sum,0,sizeof(sum));
    		for(i=1;i<=num;i++)
    		{
    			dp2[i]=0x3f3f3f3f;
    		}
    
    		for(i=1;i<=num;i++)
    		{
    			cin>>dp1[i]>>value[i];
    			sum[i]=sum[i-1]+dp1[i];
    		}
    		dp2[1]=(dp1[1]+10)*value[1];
    		for(i=1;i<=num;i++)
    		{
    			for(j=0;j<i;j++)
    			{
    				dp2[i]=min(dp2[i],dp2[j]+(sum[i]-sum[j]+10)*value[i]);
    			}
    		}
    		cout<<dp2[num]<<endl;
    	}
    	return 0;
    }


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    python_Day1_基础知识开篇
    大话Hadoop版本
    linux查看防火墙状态及开启关闭命令(转)
    Zabbix系列-REHL6.10离线方式安装Zabbix 4.0 LTS
    查看Linux系统版本信息的几种方法
    Linux常用命令学习随笔
    jenkins安装部署全过程
    集中式日志系统 ELK 协议栈详解
    ELK日志分析平台.1-搭建
    elasticsearch-6.0.1安装
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785773.html
Copyright © 2011-2022 走看看