zoukankan      html  css  js  c++  java
  • POJ 1740:A New Stone Game

    A New Stone Game

    Time Limit: 1000MS Memory Limit: 30000K
    Total Submissions: 5113 Accepted: 2806

    Description
    Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn.
    At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
    For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
    2 1 4 2
    1 2 4 2(move one stone to Pile 2)
    1 1 5 2(move one stone to Pile 3)
    1 1 4 3(move one stone to Pile 4)
    0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
    0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
    0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
    0 3 4 2(move two stones to Pile 2)
    0 1 6 2(move two stones to Pile 3)
    0 1 4 4(move two stones to Pile 4)
    Alice always moves first. Suppose that both Alice and Bob do their best in the game.
    You are to write a program to determine who will finally win the game.

    Input
    The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100.
    The last test case is followed by one zero.

    Output
    For each test case, if Alice win the game,output 1,otherwise output 0.

    Sample Input
    3
    2 1 3
    2
    1 1
    0

    Sample Output
    1
    0

    题意:Alice和Bob没事就喜欢玩游戏,玩的还竟都是本身特别无聊但一出题就特别高端的那种拿石子游戏(……)。给定几个堆的石子,A和B分别拿一个堆中任意数量的石子,然后可放可不放到其他有石子的堆中,谁最后没有石子拿谁就输了。每次都是A先拿,输出1代表A赢,输出0代表B赢

    发现现在做过的题,包括博弈论还有很多类型的题目,都是从最小的情况最简单的情况开始想,之后在往后面去推,当然dp这种就更不用说了。假设就有一个堆,那肯定是A赢,因为A直接把所有的石子拿走,B就没有石子拿了。假设有两个堆,如果是两个相等的堆,那就是B赢。因为A无论怎么拿,B都可以在另一个堆上做相同的动作,导致一定是B拿到了最后的石子。如果是两个不同数量的堆,那又一定是A赢,因为A先拿,可以导致上面相等的堆的情况,而这时A、B的拿的顺序已经换过来了,所以A赢。所以这时我们会发现拿走石子可以,放回石子到其他有石子的堆里这个动作是没有用的,因为A、B都采取最好策略,每一堆石子数量比不放回的情况多是没有用的,最后也都是拿走的命。所以就这么一直地推下去,会发现整个过程就是看石子堆是不是一对一对的过程,奇数堆的一定是A赢,偶数堆的要是一对一对就是B赢,否则就是A赢。这样代码就好写了

    所以这次做题的经验就是以后拿到博弈的题目,都要从最小最简单的情况搞起,再往后面推是一个好方法。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    using namespace std;
    
    int n[105];
    
    int main()
    {
        int num;
        while(cin>>num)
        {
            if(!num)
                break;
            memset(n,0,sizeof(n));
    
            int i,temp;
    
            if(num%2)
            {
                for(i=1;i<=num;i++)
                    cin>>temp;
                cout<<1<<endl;
            }
            else
            {
                for(i=1;i<=num;i++)
                {
                    cin>>temp;
                    n[temp]++;
                }
                int flag=0;
                for(i=0;i<=104;i++)
                {
                    if(n[i]%2)
                        flag=1;
                }
                if(flag)
                    cout<<1<<endl;
                else
                    cout<<0<<endl;
            }
        }
        return 0;
    }
    

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    vue hover如何触发事件?
    防止 window.open 被拦截
    input输入框change和blur事件区别
    神马?使用JS直接上传并预览粘贴板的图片?
    删除设备与驱动器中百度网盘图标
    枚举类字典代码 草稿
    中文转换成阿拉伯数字
    Java对象与类中的一个小练习
    正向代理和反向代理
    MySQL教程126-MySQL事务隔离级别
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785850.html
Copyright © 2011-2022 走看看