zoukankan      html  css  js  c++  java
  • POJ 1028:Web Navigation

    Web Navigation
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 30828   Accepted: 13821

    Description

    Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this. 
    The following commands need to be supported: 
    BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored. 
    FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored. 
    VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied. 
    QUIT: Quit the browser. 
    Assume that the browser initially loads the web page at the URL http://www.acm.org/

    Input

    Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

    Output

    For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

    Sample Input

    VISIT http://acm.ashland.edu/
    VISIT http://acm.baylor.edu/acmicpc/
    BACK
    BACK
    BACK
    FORWARD
    VISIT http://www.ibm.com/
    BACK
    BACK
    FORWARD
    FORWARD
    FORWARD
    QUIT

    Sample Output

    http://acm.ashland.edu/
    http://acm.baylor.edu/acmicpc/
    http://acm.ashland.edu/
    http://www.acm.org/
    Ignored
    http://acm.ashland.edu/
    http://www.ibm.com/
    http://acm.ashland.edu/
    http://www.acm.org/
    http://acm.ashland.edu/
    http://www.ibm.com/
    Ignored

    水题,题意就是模拟访问网页,看当前网页到了哪里。

    代码:

    #include <iostream>
    #include <vector>
    #include <map>
    #include <algorithm>
    #include <cmath>
    #include <string>
    #include <cstring>
    using namespace std;
    
    map <int,string> web;
    
    int main()
    {	
    	//freopen("input.txt","r",stdin);
    	//freopen("out.txt","w",stdout);
    
    	string operate;
    	string website;
    
    	int cur=1,zong=1;
    	web[1]="http://www.acm.org/";
    
    	while(cin>>operate)
    	{
    		if(operate=="QUIT")
    			break;
    		if(operate=="VISIT")
    		{
    			cin>>website;
    			web[++cur]=website;
    			zong=cur;
    			cout<<website<<endl;
    		}
    		if(operate=="BACK")
    		{
    			if(cur==1)
    			{
    				cout<<"Ignored"<<endl;
    			}
    			else
    			{
    				cur--;
    				cout<<web[cur]<<endl;
    			}
    		}
    		if(operate=="FORWARD")
    		{
    			if(cur==zong)
    			{
    				cout<<"Ignored"<<endl;
    			}
    			else
    			{
    				cur++;
    				cout<<web[cur]<<endl;
    			}
    		}
    	}
    
    	//system("pause");
    	return 0;
    }



    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    201771010101 白玛次仁 《2018面向对象程序设计(Java)》第七周学习总结
    201771010101 白玛次仁 《2018面向对象程序设计(Java)课程学习进度条》
    实验六201771010101 白玛次仁
    第七周作业
    第七周上机练习
    第六周作业
    第六周上机练习
    第五周上机作业
    Java第四周作业
    Java第四次作业
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785852.html
Copyright © 2011-2022 走看看