zoukankan      html  css  js  c++  java
  • A1002 A+B for Polynomials (25)(25 分)

    1002 A+B for Polynomials (25)(25 分)

    This time, you are supposed to find A+B where A and B are two polynomials.

    Input

    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

    Output

    For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

    Sample Input

    2 1 2.4 0 3.2
    2 2 1.5 1 0.5
    

    Sample Output

    3 2 1.5 1 2.9 0 3.2
    

    思考

    这里胡凡书上写的不全面,代码修正如下。

    AC代码

    #include <stdio.h>
    #define max_n 1111
    double p[max_n] = {};//这样也可以置初值为0 
    int main() {
        int k, n, count = 0;
        double a;
        scanf("%d", &k);
        count +=k; 
        for(int i = 0; i < k; i++) {
            scanf("%d %lf", &n, &a);
            p[n] += a;
        }
        scanf("%d", &k);
        count +=k; 
        for(int i = 0; i < k; i++) {
            scanf("%d %lf", &n, &a);
            if(p[n]!=0) count--;//出现重合项-1
            p[n] += a;
            if(p[n]==0) count--;//出现重合项且一正一负抵消为0,再-1
        }
    //    for(int i = 0; i < max_n; i++) {
    //        if(p[i] != 0) {
    //            count++;
    //        }//这样计数非零项是保险的 
    //    }
        printf("%d", count);
        for(int i = max_n - 1; i >= 0; i--) {
            if(p[i] != 0) printf(" %d %.1f", i, p[i]);
        }
        return 0;
    }
    
  • 相关阅读:
    移动端屏幕适配解决方案
    ES6学习笔记(1)——模块化
    弹性盒布局学习总结
    阮一峰之webpack-demos(译)
    阮一峰的Git分支管理策略之学习总结
    移动端测试之服务器搭建
    webApp 移动Touch框架
    Javascript 严格模式详解
    caller和callee的区别
    avalon 中require.config源码分析
  • 原文地址:https://www.cnblogs.com/lingr7/p/9389177.html
Copyright © 2011-2022 走看看