zoukankan      html  css  js  c++  java
  • Fence Repair(贪心)

    Fence Repair
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 21209   Accepted: 6762

    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks 
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    类似哈夫曼树。

    /*
    3
    8 5 8
    */
    #include<iostream>
    #include<algorithm>
    #define MAX 20001
    
    using namespace std;
    
    int main()
    {
        long long ans = 0, n, sum = 0, a[MAX];
    
        cin>> n;
        
        for(int i = 0; i < n; i++){
            cin>> a[i];
        }
    
        sort(a, a+n);
    
        for(int i = 0, j; i < n-1; i++){
            
            sum = a[i] + a[i+1];
            ans += sum;
            j = i+2;
            while(j < n && a[j]<sum){a[j-1] = a[j]; j++;}
            a[j-1] = sum;
        }
        cout<<ans<<endl;
        
        system("pause");
        return 0;
    }
    世上无难事,只要肯登攀。
  • 相关阅读:
    3、总结
    三分及小例题
    约瑟夫问题的推导
    对于联通块的处理
    扩展欧几里得与二元不定方程
    js 阻止事件捕获
    原生xhr发送JSON
    $timeout
    Angularjs Ng_repeat中实现复选框选中并显示不同的样式
    为什么用Object.prototype.toString.call(obj)检测对象类型?
  • 原文地址:https://www.cnblogs.com/littlehoom/p/3430345.html
Copyright © 2011-2022 走看看