zoukankan      html  css  js  c++  java
  • PAT Advanced 1009 Product of Polynomials (25分)

    This time, you are supposed to find A×B where A and B are two polynomials.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

    N1​​ aN1​​​​ N2​​ aN2​​​​ ... NK​​ aNK​​​​

    where K is the number of nonzero terms in the polynomial, Ni​​ and aNi​​​​ (,) are the exponents and coefficients, respectively. It is given that 1, 0.

    Output Specification:

    For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

    Sample Input:

    2 1 2.4 0 3.2
    2 2 1.5 1 0.5
    
     

    Sample Output:

    3 3 3.6 2 6.0 1 1.6

    多项式相乘,我们需要注意去使用map进行存储,去除结果为0的,然后输出即可

    #include <iostream>
    #include <vector>
    #include <map>
    using namespace std;
    struct poly{
        double coeff;
        int expo;
    };
    int main()
    {
        int M;poly tmp;
        vector<poly> poly1,poly2;
        /**input*/
        cin>>M;
        while(M--){
            cin>>tmp.expo>>tmp.coeff;
            poly1.push_back(tmp);
        }
        cin>>M;
        while(M--){
            cin>>tmp.expo>>tmp.coeff;
            poly2.push_back(tmp);
        }
        map<int,double,greater<int>> m;
        /**计算*/
        for(int i=0;i<poly1.size();i++)
            for(int j=0;j<poly2.size();j++)
                m[poly1[i].expo+poly2[j].expo]+=poly1[i].coeff*poly2[j].coeff;
        /**去0*/
        for(auto it=m.begin();it!=m.end();it++)
            if(it->second==0) m.erase(it);
        /**输出*/
        cout<<m.size();
        for(auto it=m.begin();it!=m.end();it++)
            printf(" %d %.1f",it->first,it->second);
        system("pause");
        return 0;
    }
  • 相关阅读:
    基于mAppWidget实现手绘地图--索引&DEMO
    C语言数据结构----栈的定义及实现
    libvirt命令行文档
    清理系统方法
    Linux 经典电子书共享下载
    使用数组实现队列----《数据结构与算法分析---C语言描述》
    清理系统垃圾
    epoll的内部实现 & 百万级别句柄监听 & lt和et模式非常好的解释
    进程、线程、socket套接字-资源大小 & 切换代价
    网络编程学习-面向工资编程
  • 原文地址:https://www.cnblogs.com/littlepage/p/12215791.html
Copyright © 2011-2022 走看看