zoukankan      html  css  js  c++  java
  • PAT Advanced 1096 Consecutive Factors (20分)

    Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

    Input Specification:

    Each input file contains one test case, which gives the integer N (1<N<).

    Output Specification:

    For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

    Sample Input:

    630
    
     

    Sample Output:

    3
    5*6*7

    最大连乘因子,我们找的是最大连乘因子,所以,我们从2到sqrt(n)进行遍历,因为永远到不了sqrt(n),

    之后进行遍历计算。

    #include <iostream>
    #include <vector>
    #include <cmath>
    using namespace std;
    int main(){
        long int N, sqrt_n;
        cin >> N;
        sqrt_n = sqrt(N);
        vector<int> m, tmp_v;
        for(int i = 2; i <= sqrt_n; i++){
            int cp_i = i, sum = i;
            while(N % sum == 0 && cp_i <= sqrt_n){
                tmp_v.push_back(cp_i);
                cp_i++;
                sum *= cp_i;
            }
            if(tmp_v.size() > m.size())
                m = tmp_v;
            tmp_v.clear();
        }
        if(m.size() == 0) cout << 1 << endl << N;
        else {
            cout << m.size() << endl;
            for(int i = 0; i < m.size(); i++)
                if(i != m.size() - 1) cout << m[i] << "*";
                else cout << m[i];
        }
        system("pause");
        return 0;
    }
  • 相关阅读:
    转 IDEA 解决代码提示功能消失
    模态框居中显示
    DetachedCriteria和Criteria的使用方法
    struts2配置文件详解
    springMVC上传图片
    在linux下运行mongodb
    webSocket客服在线交谈
    接口自动化
    easyui input文本框清除值
    Spring总结
  • 原文地址:https://www.cnblogs.com/littlepage/p/12233061.html
Copyright © 2011-2022 走看看