zoukankan      html  css  js  c++  java
  • PAT Advanced 1019 General Palindromic Number (20分)

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b2, where it is written in standard notation with k+1 digits ai​​ as (. Here, as usual, 0 for all i and ak​​ is non-zero. Then N is palindromic if and only if ai​​=aki​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

    Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and b, where 0 is the decimal number and 2 is the base. The numbers are separated by a space.

    Output Specification:

    For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "ak​​ ak1​​ ... a0​​". Notice that there must be no extra space at the end of output.

    Sample Input 1:

    27 2
    
     

    Sample Output 1:

    Yes
    1 1 0 1 1
    
     

    Sample Input 2:

    121 5
    
     

    Sample Output 2:

    No
    4 4 1
    
     

    鸣谢网友“CCPC拿不到牌不改名”修正数据!

    题意:判断一个树在n进制下,是否是回文数。

    我们使用两个双端队列进行存储回文。

    一个从队头插入,一个从队尾插入,然后遍历一遍,比较一下两个队列的数据是否一样。

    如果一样输出Yes,否则输出No。最后输出一下这个数。

    #include <iostream>
    #include <deque>
    using namespace std;
    int main(){
        int N, R;
        cin >> N >> R;
        deque<int> d, dr;
        while(N != 0){
            d.push_back(N % R);
            dr.push_front(N % R);
            N /= R;
        }
        bool right = true;
        for(int i = 0; i < d.size(); i++)
            if(d[i] != dr[i]) right = false;
        cout << (right ? "Yes" : "No") << endl;
        for(int i = 0; i < dr.size(); i++)
            if(i != 0) cout << " " << dr[i];
            else cout << dr[i];
        return 0;
    }
  • 相关阅读:
    java
    java
    java
    js
    java
    异常之异常处理
    面向对象之元类
    面向对象之内置方法
    面向对象之反射
    面向对象之类方法与静态方法
  • 原文地址:https://www.cnblogs.com/littlepage/p/12235726.html
Copyright © 2011-2022 走看看