zoukankan      html  css  js  c++  java
  • PAT Advanced 1024 Palindromic Number (25分)

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

    Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤) is the initial numer and K (≤) is the maximum number of steps. The numbers are separated by a space.

    Output Specification:

    For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

    Sample Input 1:

    67 3
    
     

    Sample Output 1:

    484
    2
    
     

    Sample Input 2:

    69 3
    
     

    Sample Output 2:

    1353
    3

    这题用Java贼方便,直接逆序相加,用BigInteger不用考虑溢出问题。

    import java.math.BigInteger;
    import java.util.Scanner;
    public class Main {
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            BigInteger b = sc.nextBigInteger();
            int cnt = sc.nextInt(), i;
            for(i = 0; i < cnt; i++) 
                if(b.toString().equals(new StringBuilder(b.toString()).reverse().toString())) break;
                else b = new BigInteger(new StringBuilder(b.toString()).reverse().toString()).add(b);
            System.out.println(b + "
    " + i);
        }
    }
  • 相关阅读:
    【代码审计】XDCMS 报错注入
    【渗透测试】MS17-010 "永恒之蓝" 修复方案
    【代码审计】MenInfo文件包含漏洞
    【代码总结】数据库抽象层PDO
    【代码总结】PHP面向对象之接口与多态性应用
    【代码总结】PHP面向对象之抽象类
    东哥手把手带你刷二叉树(第一期)
    二叉树的序列化,就那几个框架,枯燥至极
    二叉堆详解实现优先级队列
    递归反转链表的一部分
  • 原文地址:https://www.cnblogs.com/littlepage/p/12247426.html
Copyright © 2011-2022 走看看