zoukankan      html  css  js  c++  java
  • 1140 Look-and-say Sequence (20分)

    Look-and-say sequence is a sequence of integers as the following:

    D, D1, D111, D113, D11231, D112213111, ...
    
     

    where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

    Input Specification:

    Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

    Output Specification:

    Print in a line the Nth number in a look-and-say sequence of D.

    Sample Input:

    1 8
    
     

    Sample Output:

    1123123111
    
     
    作者
    CHEN, Yue
    单位
    浙江大学
    代码长度限制
    16 KB
    时间限制
    400 ms
    内存限制

    这道题是数数字,我们进行遍历字符串,数一共多少连续数字即可。

    #include <iostream>
    using namespace std;
    string cal(string s) {
        string ans = "";
        char ch = s[0], cnt = 1;
        for(int i = 1; i < s.length(); i++) {
            if(s[i] != s[i - 1]) {
                ans += ch;
                ans += (cnt + '0');
                ch = s[i];
                cnt = 1;
            } else cnt++;
        }
        ans += ch;
        ans += (cnt + '0');
        return ans;
    }
    int main() {
        string D; int N;
        cin >> D >> N;
        while(--N) D = cal(D);
        cout << D;
        return 0;
    }
  • 相关阅读:
    SDK安装教程
    appscan下载
    app测试-兼容性测试与云测试技术
    app测试之耗电量测试
    App测试1-App测试概述
    app测试2--monkey稳定性测试
    app测试1--常用adb命令
    常用dos命令
    jmeter(二)脚本录制
    jmeter基础介绍
  • 原文地址:https://www.cnblogs.com/littlepage/p/12818606.html
Copyright © 2011-2022 走看看