zoukankan      html  css  js  c++  java
  • 1117 Eddington Number (25分)

    British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

    Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤).

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

    Output Specification:

    For each case, print in a line the Eddington number for these N days.

    Sample Input:

    10
    6 7 6 9 3 10 8 2 7 8
    
     

    Sample Output:

    6

    艾丁顿数,求大于N的骑车天数大于N

    #include <iostream>
    #include <vector>
    #include <algorithm>
    using namespace std;
    int main() {
        int N, e = 0;
        scanf("%d", &N);
        vector<int> v(N);
        for(int i = 0; i < N; i++) 
            scanf("%d", &v[i]);
        sort(v.begin(), v.end(), greater<int>());
        while(e < N && v[e] > e+1) e++;
        printf("%d", e);
        return 0;
    }
  • 相关阅读:
    oracle数据类型
    hive的union,hive连接查询的优化,mapjoin的设置参数
    hive分隔符
    hive load数据到表的方式
    hive的常用命令操作与数据类型以及hive的严格模式
    hadoop fs 与 dfs 的区别
    pl/sql程序语法,存储过程, orcle服务
    mysql连接启动
    HTTP协议
    php6
  • 原文地址:https://www.cnblogs.com/littlepage/p/12852530.html
Copyright © 2011-2022 走看看