zoukankan      html  css  js  c++  java
  • 1109 Group Photo (25分)

    Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

    • The number of people in each row must be / (round down to the nearest integer), with all the extra people (if any) standing in the last row;

    • All the people in the rear row must be no shorter than anyone standing in the front rows;

    • In each row, the tallest one stands at the central position (which is defined to be the position (, where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);

    • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

    • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

    Now given the information of a group of people, you are supposed to write a program to output their formation.

    Input Specification:

    Each input file contains one test case. For each test case, the first line contains two positive integers N (≤), the total number of people, and K (≤), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

    Output Specification:

    For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

    Sample Input:

    10 3
    Tom 188
    Mike 170
    Eva 168
    Tim 160
    Joe 190
    Ann 168
    Bob 175
    Nick 186
    Amy 160
    John 159
    
     

    Sample Output:

    Bob Tom Joe Nick
    Ann Mike Eva
    Tim Amy John

    考察排序,队列,已知一组人 N个人,给定一个固定行K,我们插入K行,按照身高从高到底每行 N/K,多余人插入第一行。

    之后每行中,进行交错插入,先后再前。最后打印

    #include <iostream>
    #include <deque>
    #include <vector>
    #include <algorithm>
    using namespace std;
    int N, K;
    bool cmp(pair<string, int>& p1, pair<string, int>& p2) {
        if(p1.second != p2.second) return p1.second > p2.second;
        return p1.first < p2.first;
    }
    int main() {
        cin >> N >> K;
        int col = N / K;
        vector<pair<string, int>> v(N);
        for(int i = 0; i < N; i++)
            cin >> v[i].first >> v[i].second;
        sort(v.begin(), v.end(), cmp);
        vector<deque<pair<string, int>>> tmp(K), ans(K);
        int i;
        for(i = 0; i < N - K * col; i++) 
            tmp[0].push_back(v[i]);
        for(int j = 0; j < K; j++) 
            for(int k = 0; k < col; k++, i++)
                tmp[j].push_back(v[i]);
        for(int j = 0; j < K; j++) {
            bool flag = 0;
            for(int k = 0; k < tmp[j].size(); k++) {
                if(flag) ans[j].push_front(tmp[j][k]);
                else ans[j].push_back(tmp[j][k]);
                flag = !flag;
            }
        }
        for(int j = 0; j < K; j++) {
            cout << ans[j][0].first;
            for(int k = 1; k < ans[j].size(); k++) 
                cout << " " << ans[j][k].first;
            cout << endl;
        }
        return 0;
    }
  • 相关阅读:
    Java中 Jwt
    Python中Jwt
    jwt流程
    Vue Demons
    Vue基础
    Mysql
    MongoDb
    2020/03/07-基础复习day_02
    2020/03/07-基础复习day_01
    基于springboot+dubbo的简易分布式小Demo
  • 原文地址:https://www.cnblogs.com/littlepage/p/12868978.html
Copyright © 2011-2022 走看看