zoukankan      html  css  js  c++  java
  • POJ2411 铺地砖 Mondriaan's Dream

    Mondriaan's Dream
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 15962   Accepted: 9237

    Description

    Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 

    Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

    Input

    The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

    Output

    For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

    Sample Input

    1 2
    1 3
    1 4
    2 2
    2 3
    2 4
    2 11
    4 11
    0 0
    

    Sample Output

    1
    0
    1
    2
    3
    5
    144
    51205
     
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    long long dp[13][1<<11];
    int n,m;
     
    void dfs(int i,int j,int state,int next)
    {
        if(j==m)
        {
            dp[i+1][next] += dp[i][state];
            return;
        }
        if(((1<<j)&state) > 0)
            dfs(i,j+1,state,next);
        if(((1<<j)&state) == 0)
            dfs(i,j+1,state,next|(1<<j));
        if(j<=m-2 && ((1<<j)&state) == 0 && ((1<<(j+1))&state) == 0)
            dfs(i,j+2,state,next);
        return;
    }
     
    int main()
    {
        while(scanf("%d%d",&n,&m)&&(n||m))
        {
            if(n%2==1&&m%2==1){
                printf("0 ");
                continue;
            }
            if(n<m) swap(n,m);
            memset(dp,0,sizeof(dp));
            dp[1][0] = 1;
            for(int i=1;i<=n;i++)
            {
                for(int j=0;j<(1<<m);j++)
                {
                    if(dp[i][j])
                        dfs(i,0,j,0);
                }
            }
            printf("%lld ",dp[n+1][0]);
        }
    }





  • 相关阅读:
    Android中Tomcat的简单配置和使用
    Android Toast 总结(五种用法)
    软件工程—软件开发生命周期
    Android四大组件之BroadcastReceiver
    Android之 Fragment
    Android 四大组件之Acticity
    java 注解Annotation
    Android Intent的使用
    Android 调用webService(.net平台)
    关于TouchEvent中出现异常:MessageQueue-JNI问题
  • 原文地址:https://www.cnblogs.com/liwenchi/p/7259376.html
Copyright © 2011-2022 走看看