zoukankan      html  css  js  c++  java
  • HDU 4288 Coder

    Coder

    Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 2431    Accepted Submission(s): 969


    Problem Description
      In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now employ a single coder to write an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done. 1
      You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete).
    Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum.
      By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations:
      1. add x – add the element x to the set;
      2. del x – remove the element x from the set;
      3. sum – find the digest sum of the set. The digest sum should be understood by

      where the set S is written as {a1, a2, ... , ak} satisfying a1 < a2 < a3 < ... < ak 
      Can you complete this task (and be then fired)?
    ------------------------------------------------------------------------------
    1 See http://uncyclopedia.wikia.com/wiki/Algorithm
     

    Input
      There’re several test cases.
      In each test case, the first line contains one integer N ( 1 <= N <= 105 ), the number of operations to process.
      Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”.
      You may assume that 1 <= x <= 109.
      Please see the sample for detailed format.
      For any “add x” it is guaranteed that x is not currently in the set just before this operation.
      For any “del x” it is guaranteed that x must currently be in the set just before this operation.
      Please process until EOF (End Of File).
     

    Output
      For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty.
     

    Sample Input
    9 add 1 add 2 add 3 add 4 add 5 sum add 6 del 3 sum 6 add 1 add 3 add 5 add 7 add 9 sum
     

    Sample Output
    3 4 5
    Hint
    C++ maybe run faster than G++ in this problem.
     

    Source
     
       5棵线段树。离散化,直接用STL方便写,网上有的代码感觉有点小问题。
    #include <iostream>
    #include <stdio.h>
    #include <queue>
    #include <stdio.h>
    #include <string.h>
    #include <vector>
    #include <queue>
    #include <set>
    #include <algorithm>
    #include <map>
    #include <stack>
    #include <math.h>
    #define Max(a,b) ((a)>(b)?(a):(b))
    #define Min(a,b) ((a)<(b)?(a):(b))
    using namespace std ;
    typedef __int64 LL ;
    #define Lson id<<1
    #define Rson id<<1|1
    const int Max_N=100008  ;
    struct Seg{
         int  Left ;
         int  Right ;
         int  num_size ;
         LL  Sum[5] ;
    }seg[Max_N*4];
    
    void make_tree(int id ,int L ,int R){
         seg[id].Left=L ;
         seg[id].Right=R ;
         seg[id].num_size=0 ;
         for(int i=0;i<5;i++)
            seg[id].Sum[i]=0 ;
         if(L==R)
             return  ;
         int mid=(L+R)>>1 ;
         make_tree(Lson,L,mid) ;
         make_tree(Rson,mid+1,R) ;
    }
    
    void push_up(int id){
        for(int i=0;i<5;i++)
            seg[id].Sum[i]=seg[Lson].Sum[i]+seg[Rson].Sum[((i-seg[Lson].num_size%5)%5+5)%5] ;
    }
    
    void update(int id ,int pos ,int val ,int kind){
         seg[id].num_size+=kind ;
         if(seg[id].Left==seg[id].Right){
               seg[id].Sum[0]+=val  ;
               return  ;
         }
         if(pos<=seg[Lson].Right)
              update(Lson,pos,val,kind) ;
         else
              update(Rson,pos,val,kind) ;
         push_up(id) ;
    }
    
    struct Query{
         char name[5] ;
         int  X ;
    };
    Query query[Max_N] ;
    int A[Max_N]  ;
    int main(){
       int N ,M ,I;
       while(scanf("%d",&N)!=EOF){
            I=0 ;
            for(int i=0;i<N;i++){
                scanf("%s",query[i].name) ;
                if(query[i].name[0]=='s')
                    continue ;
                scanf("%d",&query[i].X) ;
                A[I++]=query[i].X ;
            }
            sort(A,A+I) ;
            M=unique(A,A+I)-A ;
            make_tree(1,1,M) ;
            for(int i=0;i<N;i++){
                if(query[i].name[0]=='s')
                     cout<<seg[1].Sum[2]<<endl ;
                else{
                     int pos=lower_bound(A,A+M,query[i].X)-A ;
                     pos++ ;
                     if(query[i].name[0]=='a')
                        update(1,pos,query[i].X,1) ;
                     else
                        update(1,pos,-query[i].X,-1) ;
                }
            }
       }
       return 0 ;
    }

  • 相关阅读:
    浏览器渲染机制
    isEmpty 和 isBlank 的用法区别
    Mybatis-plus
    Java8的JVM内存结构
    【面试题】关于线程交替的面试题
    java中的final的作用
    线程池
    六种实现单例模式的方法
    SQL优化常用方法
    HTML学习笔记
  • 原文地址:https://www.cnblogs.com/liyangtianmen/p/3379606.html
Copyright © 2011-2022 走看看