zoukankan      html  css  js  c++  java
  • 继续畅通工程

    B - 继续畅通工程
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
    Submit Status

    Description

    省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。 
     

    Input

    测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。 

    当N为0时输入结束。
     

    Output

    每个测试用例的输出占一行,输出全省畅通需要的最低成本。
     

    Sample Input

    3 1 2 1 0 1 3 2 0 2 3 4 0 3 1 2 1 0 1 3 2 0 2 3 4 1 3 1 2 1 0 1 3 2 1 2 3 4 1 0
     

    Sample Output

    3 1 0
     
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    const int MAXX = 100005;
    int father[MAXX];
    bool vis[MAXX];
    struct kruskal
    {
        int a;
        int b;
        int value;
    };
    kruskal edge[MAXX];
    int find(int x)
    {
        return x==father[x]?x:find(father[x]);
    }
    bool unionsearch(int a,int b)
    {
        int fa = find (a);
        int fb = find (b);
        if(fa==fb)
            return false;
        else
        {
            father[fb] = fa;
            return true;
        }
    }
    bool cmp(const kruskal&a,const kruskal&b)
    {
    return a.value<b.value;
    }
    int main()
    {
        int num;
        while(scanf("%d",&num)&&num)
        {
            int ans_value =0;
            memset(edge,0,sizeof(kruskal));
            for(int i =1;i<=num;i++)
            {
                father[i] = i;
            }
            int n = num*(num-1)/2;
            int N=1;
            for(int i = 1;i<=n;i++)
            {
                int a,b,value,flag;
                scanf("%d %d %d %d",&a,&b,&value,&flag);
                if(flag)
                {
                    unionsearch(a,b);
                }
                else
                {
                    edge[N].a = a;
                    edge[N].b = b;
                    edge[N++].value = value;
                }
            }
            sort(edge+1,edge+N,cmp);
            for(int i = 1;i<N;i++)
            {
                if(unionsearch(edge[i].a,edge[i].b))
                {
                    ans_value +=edge[i].value;
                }
            }
            cout<<ans_value<<endl;
        }
        return 0;
    }
    

      

     
  • 相关阅读:
    小白开学Asp.Net Core 《一》
    小白开学Asp.Net Core 开篇
    分享一个.NET平台开源免费跨平台的大数据分析框架.NET for Apache Spark
    微信支付退款中发现的一个问题
    发布mvc遇到的HTTP错误 403.14-Forbidden解决办法
    English--元音
    开发工具--浅谈Git
    开发工具--搭建python环境
    开发工具--PyCharm
    English--介词省略句型与总结
  • 原文地址:https://www.cnblogs.com/locojyw/p/3716145.html
Copyright © 2011-2022 走看看