zoukankan      html  css  js  c++  java
  • STL训练 HDU

    HDU - 1716 Ray又对数字的列产生了兴趣:

    现有四张卡片,用这四张卡片能排列出很多不同的4位数,要求按从小到大的顺序输出这些4位数。
    Input
    每组数据占一行,代表四张卡片上的数字(0<=数字<=9),如果四张卡片都是0,则输入结束。
    Output
    对每组卡片按从小到大的顺序输出所有能由这四张卡片组成的4位数,千位数字相同的在同一行,同一行中每个四位数间用空格分隔。
    每组输出数据间空一行,最后一组数据后面没有空行。
    Sample Input 1 2 3 4
    1 1 2 3
    0 1 2 3
    0 0 0 0
    Sample Output
    1234 1243 1324 1342 1423 1432
    2134 2143 2314 2341 2413 2431
    3124 3142 3214 3241 3412 3421
    4123 4132 4213 4231 4312 4321
    1123 1132 1213 1231 1312 1321
    2113 2131 2311
    3112 3121 3211
    1023 1032 1203 1230 1302 1320
    2013 2031 2103 2130 2301 2310
    3012 3021 3102 3120 3201 3210

    思路,使用全排列next_permat 或通过一个不断排列组合用

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<map>
    #include<set>
    #include<algorithm>
    using namespace std;
    set<int> mx;
    int main()
    {
        int a[5];
        int sb=0;
        for(;;)
        {
            mx.clear();
            int multi;
            for(int i=1;i<5;i++)
            {
                cin>>a[i];
            }
            if(a[1]==0&&a[2]==0&&a[3]==0&&a[4]==0) break;
            if(sb)cout<<endl;
            sb++;
            for(int i=1;i<5;i++)
            {
                for(int j=1;j<5;j++)
                {
                    if(i==j) continue;
                    for(int k=1;k<5;k++)
                    {
                        if(j==k||i==k) continue;
                        for(int l=1;l<5;l++)
                        {
                            if(k==l||l==j||l==i) continue;
                            multi=a[i]*1000+a[j]*100+a[k]*10+a[l];
                            if(multi>999) mx.insert(multi);
                        }
                    }
                }
            }
            set<int>::iterator poi,p2;
            p2=mx.begin();
            int xa=0;
            for(poi=mx.begin();poi!=mx.end();poi++)
            {
                p2++;
                if(xa) cout<<' ';
                xa++;
                cout<<*poi;
                if(*p2/1000!=*poi/1000)
                {
                    cout<<endl;
                    xa=0;
                }
            }
        }
        return 0;
    }
    

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<map>
    #include<set>
    #include<algorithm>
    using namespace std;
    int main()
    {
        char a[4]={0};
        int x=0;
        for(;;)
        {
            for(int i=0;i<4;i++)
            {
                cin>>a[i];
            }
            sort(a,a+4);
            char w=a[0];
            if(a[0]=='0'&&a[1]=='0'&&a[3]=='0'&&a[2]=='0') break;
            if(x) cout<<endl;
            x++;
            int qt=0;
            int lasta0=-1;
            bool flag2=true;
           do {
                if(a[0]=='0')continue;
                if(flag2)flag2 = false;
                else if(a[0] == lasta0) cout<<' ';
                else  cout<<endl;
               cout<<a[0]<<a[1]<<a[2]<<a[3];
                lasta0 = a[0];
            } while(next_permutation(a, a +4));
            cout<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    mysql 数据库初识
    Python3进行RSA2加密、解密、签名
    jenkins一次构建两次触发job问题
    docker 端口被占用问题解决
    jacoco 的使用及与jenkins的集成
    python 学习笔记二 (列表推导式)
    python 学习笔记一 (数据结构和算法)
    请求超时及重试的设置
    python 中 str与bytes的转换
    JS模块化
  • 原文地址:https://www.cnblogs.com/lunatic-talent/p/12799067.html
Copyright © 2011-2022 走看看