zoukankan      html  css  js  c++  java
  • ZOJ Problem Set–1350 The Drunk Jailer

    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked.

    One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey, and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the hall locking every other cell (cells 2, 4, 6, ...). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ...). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He repeats this for n rounds, takes a final drink, and passes out.

    Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape.

    Given the number of cells, determine how many prisoners escape jail.


    Input

    The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.

    Output
    For each line, you must print out the number of prisoners that escape when the prison has n cells.

    Sample Input

    2
    5
    100

    Sample Output

    2
    10


    Source: Greater New York 2002

    这题是考循环控制的,初学程序设计的人可以做一下,增强对循环的理解。

    #include<iostream>
    
    #include<bitset>
    
    using namespace std;
    
    int main()
    
    {
    
      int lines,n;cin>>lines;
    
      while(lines-- && cin>>n)
    
      {
    
        bool *pCells = new bool[n];
    
        bool locked = false;
    
        for(int i = 0; i < n; i++)//初始化所有监狱,在第一轮中所有监狱被打开
    
        {
    
          *(pCells + i) = locked;
    
        }
    
        for(int j = 2; j <= n;j++)
    
        {
    
          for(int k = j; k <= n;k += j)
    
          {
    
            *(pCells + k - 1) = !*(pCells + k - 1);
    
          }
    
        }
    
        int unlockedCell = 0;
    
        for(int z = 0; z < n; z++)
    
        {
    
          if(!*(pCells + z))
    
            unlockedCell++;
    
        }
    
        cout<<unlockedCell<<endl;
    
        delete []pCells;
    
      }
    
      return 0;
    
    }
  • 相关阅读:
    窗口生效函数UpdateData
    查找内容grep命令
    终止函数 atexit()
    根据名字杀死进程Killall
    修改系统时间为UTC时间
    转 proc文件
    NTP算法
    转载,网线的深刻理解
    js完成密码输入为空,和两次输入不一致
    CSS初步了解
  • 原文地址:https://www.cnblogs.com/malloc/p/2393618.html
Copyright © 2011-2022 走看看