zoukankan      html  css  js  c++  java
  • ZOJ Problem Set–1494 Climbing Worm

    Time Limit: 2 Seconds      Memory Limit: 65536 KB


    An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.

    Input
    There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.

    Output
    Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.

    Sample Input
    10 2 1
    20 3 1
    0 0 0

    Sample Output
    17
    19


    Source: East Central North America 2002

    #include<iostream>
    
    using namespace std;
    
    int main()
    
    {
    
      int n, u, d;
    
      while(cin>>n>>u>>d && n)
    
      {
    
        int upInches = 0;
    
        int minutes = 0;
    
        while(upInches < n)
    
        {
    
          minutes++;
    
          upInches += u;
    
          if(upInches >= n)
    
            break;
    
          upInches -= d;
    
          minutes++;
    
        }
    
        cout<<minutes<<endl;
    
      }
    
    }
  • 相关阅读:
    【51nod1674】区间的价值 V2(算法效率--位运算合并优化+链表实现)
    【bzoj 2339】[HNOI2011]卡农(数论--排列组合+逆元+递推)
    关于中国剩余定理{附【转】中国剩余定理 }
    JavaScript操作BOM
    学员操作—统计考试平均成绩
    JavaScript基础
    JDBC
    进制
    事务
    复习
  • 原文地址:https://www.cnblogs.com/malloc/p/2425506.html
Copyright © 2011-2022 走看看