zoukankan      html  css  js  c++  java
  • ZOJ Problem Set 1088 System Overload

    ZOJ Problem Set - 1088
    System Overload

    Time Limit: 10 Seconds      Memory Limit: 32768 KB

    Recently you must have experienced that when too many people use the BBS simultaneously, the net becomes very, very slow.
    To put an end to this problem, the Sysop has developed a contingency scheme for times of peak load to cut off net access for some buildings of the university in a systematic, totally fair manner. Our university buildings were enumerated randomly from 1 to n. XWB is number 1, CaoGuangBiao (CGB) Building is number 2, and so on in a purely random order.
    Then a number m would be picked at random, and BBS access would first be cut off in building 1 (clearly the fairest starting point) and then in every mth building after that, wrapping around to 1 after n, and ignoring buildings already cut off. For example, if n=17 and m=5, net access would be cut off to the buildings in the order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7]. The problem is that it is clearly fairest to cut off CGB Building last (after all, this is where the best programmers come from), so for a given n, the random number m needs to be carefully chosen so that building 2 is the last building selected.

    Your job is to write a program that will read in a number of buildings n and then determine the smallest integer m that will ensure that our CGB Building can surf the net while the rest of the university is cut off.

    Input Specification

    The input file will contain one or more lines, each line containing one integer n with 3 <= n < 150, representing the number of buildings in the university.
    Input is terminated by a value of zero (0) for n.

    Output Specification

    For each line of the input, print one line containing the integer m fulfilling the requirement specified above.

    Sample Input

    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    0
    

    Sample Output

    2
    5
    2
    4
    3
    11
    2
    3
    8
    16

    Source: University of Ulm Local Contest 1996
     
     
    #include<iostream>
    #include<bitset>
    using namespace std;
    
    const int MAX_N = 150;
    bitset<MAX_N> building;
    
    void init_bitset(int n)
    {
        building.set();
        for(int pos = n; pos < 150; pos++)
            building.reset(pos);
    }
    
    bool doBusiness(int m, int n)
    {
        int pos = 0%n;
        building.reset(0);
        while(building.test(1))
        {
            for(int j = 0; j < m; )
            {
                pos = (++pos)%n;
                if(building.test(pos))
                    j++;
            }
            while(true)
            {
                if(building.test(pos))
                {
                    building.reset(pos);
                    if(pos == 1)
                        return !building.any();
                    break;
                }
                else
                {
                    pos = (pos + 1)%n;
                }
            }
        }
        return false;
    }
    
    int main(void)
    {
        int n;
        while(cin>>n && n)
        {
            for(int m = 2;;m++)
            {
                init_bitset(n);
                if(doBusiness(m, n))
                {
                    cout<<m<<endl;
                    break;
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    linux 配置ssh免密码登陆本机
    Java连接mysql数据库并插入中文数据显示乱码
    新浪微博热门评论爬虫采集
    新浪微博热门评论抽取规则
    【MySql】Java 批量插入数据库addBatch
    算法设计题4.3 等差数列
    PHP setcookie() 函数
    Linux下用于查看系统当前登录用户信息 w命令
    Ubuntu 登录锐捷 网卡被禁用 网口灯不亮解决
    将 VMware 最小化到系统托盘
  • 原文地址:https://www.cnblogs.com/malloc/p/2949872.html
Copyright © 2011-2022 走看看