zoukankan      html  css  js  c++  java
  • poj2823单调队列认知

    Sliding Window
    Time Limit: 12000MS   Memory Limit: 65536K
    Total Submissions: 62930   Accepted: 17963
    Case Time Limit: 5000MS

    Description

    An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
    The array is [1 3 -1 -3 5 3 6 7], and k is 3.
    Window positionMinimum valueMaximum value
    [1  3  -1] -3  5  3  6  7  -1 3
     1 [3  -1  -3] 5  3  6  7  -3 3
     1  3 [-1  -3  5] 3  6  7  -3 5
     1  3  -1 [-3  5  3] 6  7  -3 5
     1  3  -1  -3 [5  3  6] 7  3 6
     1  3  -1  -3  5 [3  6  7] 3 7

    Your task is to determine the maximum and minimum values in the sliding window at each position.

    Input

    The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

    Output

    There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

    Sample Input

    8 3
    1 3 -1 -3 5 3 6 7
    

    Sample Output

    -1 -3 -3 -3 3 3
    3 3 5 5 6 7
    
    #include<cstdio>
    const int N=1e6+88;
    int a[N],q[N];
    int main()
    {
        int n,k;
        scanf("%d%d",&n,&k);
        for(int i=1; i<=n; ++i) scanf("%d",&a[i]);
        if(k==1)
        {
            for(int i=1; i<=n; ++i) printf("%d ",a[i]);
            puts("");
            for(int i=1; i<=n; ++i) printf("%d ",a[i]);
            puts("");
            return 0;
        }
        int h=1,t=1;
        q[1]=1;
        for(int i=2; i<=n; ++i)
        {
            if(i-q[h]==k) ++h;
            if(a[i]>a[q[t]]) q[++t]=i;
            else
            {
                while(t>=h&&a[i]<=a[q[t]]) q[t--]=i;
                ++t;
            }
            if(i>=k) printf("%d ",a[q[h]]);
        }
        puts("");
        h=1,t=1,q[1]=1;
        for(int i=2; i<=n; ++i)
        {
            if(i-q[h]==k) ++h;
            if(a[i]<a[q[t]]) q[++t]=i;
            else
            {
                while(t>=h&&a[i]>=a[q[t]]) q[t--]=i;
                ++t;
            }
            if(i>=k) printf("%d ",a[q[h]]);
        }
        puts("");
    }

    http://blog.csdn.net/acdreamers/article/details/20911981//学习的这个地方




  • 相关阅读:
    SQLServer2008 行转列2
    SQLServer2008 行转列
    关于删除数据仓库的数据
    PowerDesign不让name和code联动
    提高SQL查询效率(SQL优化)(转载)
    SQL优化----百万数据查询优化(转载)
    运行程序向一个Java类中动态添加注解。
    开阔自己的视野,勇敢的接触新知识(转)
    [置顶] JAVA识别身份证号码,H5识别身份证号码,tesseract-ocr识别(一)(转)
    一个谷歌程序员的算法学习之路
  • 原文地址:https://www.cnblogs.com/mfys/p/7478388.html
Copyright © 2011-2022 走看看