zoukankan      html  css  js  c++  java
  • Problem I: Satellite Photographs

    Problem I: Satellite Photographs

    Time Limit: 1 Sec  Memory Limit: 128 MB Submit: 208  Solved: 118 [Submit][Status][Web Board]

    Description

    Farmer John purchased satellite photos of W x H pixels of his farm (1 <= W <= 80, 1 <= H <= 1000) and wishes to determine the largest 'contiguous' (connected) pasture. Pastures are contiguous when any pair of pixels in a pasture can be connected by traversing adjacent vertical or horizontal pixels that are part of the pasture. (It is easy to create pastures with very strange shapes, even circles that surround other circles.) 
    Each photo has been digitally enhanced to show pasture area as an asterisk ('*') and non-pasture area as a period ('.'). Here is a 10 x 5 sample satellite photo: 
    ..*.....**  .**..*****  .*...*....  ..****.***  ..****.*** 
    This photo shows three contiguous pastures of 4, 16, and 6 pixels. Help FJ find the largest contiguous pasture in each of his satellite photos.

    Input

    * Line 1: Two space-separated integers: W and H  * Lines 2..H+1: Each line contains W "*" or "." characters representing one raster line of a satellite photograph.

     

    Output

    * Line 1: The size of the largest contiguous field in the satellite photo.

    Sample Input

    10 5
    ..*.....**
    .**..*****
    .*...*....
    ..****.***
    ..****.***
    

    Sample Output

    16
    #include<stdio.h>
    #include<stdlib.h>
    #include<string.h>
    char a[1000][1000];
    int sum;
    void dfs(int x,int y)
    {
        if(a[x][y]=='*')//注意是单引号//
        {
            a[x][y]='.';
            sum++;
            dfs(x,y+1);
            dfs(x,y-1);
            dfs(x+1,y);
            dfs(x-1,y);
        }
        else if(a[x][y]=='.')
            return ;
    }
    int main()
    {
        int w,h;
        int i,j,k;
        int max;
        char c;
        sum=0;
        scanf("%d%d",&w,&h);
        for(i=0;i<h;i++)
        {
            for(j=0;j<w;j++)
            {
                scanf(" %c",&a[i][j]);//一定要注意空格,因为换行符也是字符//
            }
        }
        max=0;
        for(i=0;i<h;i++)
        {
            for(j=0;j<w;j++)
            {
                if(a[i][j]=='*')
                {
                    sum=0;//注意初始化sum为0!!!!!!//
                    dfs(i,j);//从二维数组的第一个*开始搜索//
                    if(sum>=max)
                        max=sum;
                }
            }
        }
        printf("%d\n",max);
        return 0;
    }
    
  • 相关阅读:
    std::copy 多次赋值 偏移 内存分配
    chromium http 处理
    c++ 智能指针 传参
    最简单的gn构建 脱离chromium
    简单的nodejs httpserver
    C语言跨文件调用变量方法
    使用node压缩js
    Jmeter压力测试工具安装及使用教程
    前端常见跨域解决方案(全)
    QuickApp 快应用中 或 nodejs 中 API接品调用时 GBK转UTF8
  • 原文地址:https://www.cnblogs.com/mjn1/p/8969268.html
Copyright © 2011-2022 走看看