zoukankan      html  css  js  c++  java
  • 1117 Eddington Number (25 分)(简单逻辑)

    British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

    Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (<=N).

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N(<=105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

    Output Specification:

    For each case, print in a line the Eddington number for these N days.

    Sample Input:

    10
    6 7 6 9 3 10 8 2 7 8

    Sample Output:

    6

    生词

    英文 解释
    astronomer 天文学家

    题目大意:

    英国天文学家爱丁顿很喜欢骑车。据说他为了炫耀自己的骑车功力,还定义了一个“爱丁顿数”E,即满足有E天骑车超过E英里的最大整数E,据说爱丁顿自己的E等于87

    分析:

    在数组a中存储n天的公里数,对n个数据从大到小排序,根据排序后的数组可得知骑车大于等于 a[i] 英里的天数有 i+1 天,因为题目中要求超过E英里且所有的英里数为整数,所以可得知骑车超过 a[i]-1 英里的天数有 i+1 天,如样例,从大到小排序后结果为10、9、8、8、7、7、6、6、3、2,骑车超过9英里的有1天,超过8英里的有2天,超过7英里的有4天/5天,超过6英里的有5天/6天,超过5英里的有7天/8天…英里数不断减少,天数不断增加,既然已知公里数和天数对应的关系,要想满足题意,必须使超过的英里数a[i]-1大于等于天数i+1(比如样例中,超过6英里的有6天,超过5英里的有7天,前者的天数6满足题意这6天都超过了6英里,后者的天数7不满足因为这7天只满足骑车都超过5英里)即a[i]-1 >= i+1,也就是 a[i] >= i + 2,也就是a[i] > i + 1~从头到尾遍历数组,那么满足a[i] > i+1的最大i+1即为所求

    原文链接:https://blog.csdn.net/liuchuo/article/details/52505043

    题解

    乙级的理解

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n,e=0;
        cin>>n;
        vector<int> v(n);
        for(int i=0; i<n; i++)
        {
            cin>>v[i];
        }
        sort(v.begin(),v.end(),greater<int>());
        while(e<n&&v[e]>e+1) e++;
        cout<<e;
        return 0;
    }
    

    本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15776728.html

  • 相关阅读:
    hud 1166 敌兵布阵
    zznu 1914 asd的甩锅计划
    poj 1860 Currency Exchange
    poj 3026 Borg Maze (BFS + Prim)
    poj 2349 Arctic Network
    POJ 1502 MPI Maelstrom
    poj 1308 Is It A Tree?
    hdu 1272 小希的迷宫
    poj 1679 http://poj.org/problem?id=1679
    POJ 2492 A Bug's Life
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15776728.html
Copyright © 2011-2022 走看看