zoukankan      html  css  js  c++  java
  • HDU 1017 A Mathematical Curiosity (数学)

    A Mathematical Curiosity

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 25871    Accepted Submission(s): 8174



    Problem Description
    Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.
     

    Input
    You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
     

    Output
    For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
     

    Sample Input
    1 10 1 20 3 30 4 0 0
     

    Sample Output
    Case 1: 2 Case 2: 4 Case 3: 5
     

    Source
     

    Recommend
    JGShining   |   We have carefully selected several similar problems for you:  1013 1018 1005 1021 1012

    对这道题不解释。题目的例子错了,那个1后面根本不要空行,还是看讨论区才知道。
    代码:78MS
     #include<iostream>  
        using namespace std;  
        int main(){  
            int n,m,cont=0,num=0;  
            int T;  
            cin>>T;  
            while(T--)  
            {  
            while(cin>>n>>m&&n!=0)  
            {         
                int a,b;  
                for(a=1;a<=n;++a){  
                for(b=a+1;b<n;++b){  
                    if((a*a+b*b+m)%(a*b)==0)  
                    cont++;  
                }  
            }  
            cout<<"Case "<<++num<<": "<<cont<<endl;  //没打空格的同学伤不起啊。

    。 cont=0; } num=0; if(T) cout<<endl; } }



  • 相关阅读:
    array、vector、forward-list、list、deque的扩容,栈与队列,基于范围的for循环
    带默认参数值的函数
    :: 访问全局变量
    using来定义类的别名,typedef,#define
    const int* p
    内存
    变量的定义,强制类型转换
    HTTP请求流程(一)----流程简介
    DIY一个DNS查询器:程序实现
    详解C/C++函数指针声明
  • 原文地址:https://www.cnblogs.com/mthoutai/p/6744822.html
Copyright © 2011-2022 走看看