zoukankan      html  css  js  c++  java
  • UESTC 1034 AC Milan VS Juventus 分情况讨论

    AC Milan VS Juventus

    Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
     

    Kennethsnow and Hlwt both love football.

    One day, Kennethsnow wants to review the match in 2003 between AC Milan and Juventus for the Championship Cup. But before the 

    penalty shootout. he fell asleep.

    The next day, he asked Hlwt for the result. Hlwt said that it scored a:b in the penalty shootout.

    Kennethsnow had some doubt about what Hlwt said because Hlwt is a fan of Juventus but Kennethsnow loves AC Milan.

    So he wanted to know whether the result can be a legal result of a penalty shootout. If it can be, output Yes, otherwise output No.

    The rule of penalty shootout is as follows:

    • There will be 5 turns, in each turn, 2 teams each should take a penalty shoot. If goal, the team get 1 point. After each shoot, if the 

    • winner can be confirmed(i.e: no matter what happened after this shoot, the winner will not change), the match end immediately.

    • If after 5 turns the 2 teams score the same point. A new turn will be added, until that one team get a point and the other not in a turn.

    Before the penalty shootout begins, the chief referee will decide which team will take the shoot first, and afterwards, two teams will take shoot 

    one after the other. Since Kennethsnow fell asleep last night, he had no idea whether AC Milan or Juventus took the first shoot.

    Input

    The only line contains 2 integers ab. Means the result that Hlwt said.

    0a,b10    

    Output

    Output a string Yes or No, means whether the result is legal.

    Sample input and output

    Sample Input Sample Output
    3 2
    Yes
    2 5
    No

    Hint

    The Sample 1 is the actual result of the match in 2003.

    The Sample 2, when it is 2:4 after 4 turns, AC Milan can score at most 1point in the next turn. So Juventus has win when it is 2:4. So the result cannot be 22:55.

    This story happened in a parallel universe. In this world where we live, kennethsnow is a fan of Real Madrid.

    Source

    The 13th UESTC Programming Contest Preliminary
    The question is from here.

    My Solution

    分情况讨论清楚就好。然后注意 a == b 的时候也是No
    把分类出来的区间理清楚。不要条件里面混杂着不该包括的东西

    #include <iostream>
    #include <cstdio>
    #include <cmath>
    using namespace std;
    
    int main()
    {
        int a, b;
        scanf("%d%d", &a, &b);
        if(a == b )printf("No");
        else if((a == 5 && b <5) || (b == 5&& a <5)) {if(abs(a-b) >= 3) printf("No");else printf("Yes"); }  //!!
        else if(a < 5 && b <5) {if(abs(a-b) >= 4) printf("No");else printf("Yes"); }
        else {if(abs(a-b) > 1) printf("No");else printf("Yes"); }
        return 0;
    }

    Thank you all!

  • 相关阅读:
    项目源码--Android迷幻岛屿综合游戏
    实例源码--Android软件更新模块
    实例源码--Android小工具源码
    项目源码--Android3D影音播放器源码
    实例源码--Android时钟源码
    实例源码--Android简单音乐播放器源码
    项目源码--Android应用商店源码
    实例源码--Android理财工具源码
    实例源码--Android手机狗(防盗)源码
    谈事务的理解
  • 原文地址:https://www.cnblogs.com/mthoutai/p/7403617.html
Copyright © 2011-2022 走看看